RHEL 7 : rh-php73-php (RHSA-2022:5491)

high Nessus Plugin ID 162704

Synopsis

The remote Red Hat host is missing one or more security updates.

Description

The remote Redhat Enterprise Linux 7 host has packages installed that are affected by multiple vulnerabilities as referenced in the RHSA-2022:5491 advisory.

- php: Local privilege escalation via PHP-FPM (CVE-2021-21703)

- php: special character breaks path in xml parsing (CVE-2021-21707)

- php: uninitialized array in pg_query_params() leading to RCE (CVE-2022-31625)

- php: password of excessive length triggers buffer overflow leading to RCE (CVE-2022-31626)

Note that Nessus has not tested for these issues but has instead relied only on the application's self-reported version number.

Solution

Update the affected packages.

See Also

https://access.redhat.com/security/cve/CVE-2021-21703

https://access.redhat.com/security/cve/CVE-2021-21707

https://access.redhat.com/security/cve/CVE-2022-31625

https://access.redhat.com/security/cve/CVE-2022-31626

https://access.redhat.com/errata/RHSA-2022:5491

https://bugzilla.redhat.com/2016535

https://bugzilla.redhat.com/2026045

https://bugzilla.redhat.com/2098521

https://bugzilla.redhat.com/2098523

Plugin Details

Severity: High

ID: 162704

File Name: redhat-RHSA-2022-5491.nasl

Version: 1.6

Type: local

Agent: unix

Published: 7/4/2022

Updated: 9/22/2022

Supported Sensors: Agentless Assessment, Frictionless Assessment Agent, Frictionless Assessment AWS, Frictionless Assessment Azure, Nessus Agent

Risk Information

VPR

Risk Factor: High

Score: 8.4

CVSS v2

Risk Factor: Medium

Base Score: 6.9

Temporal Score: 5.1

Vector: AV:L/AC:M/Au:N/C:C/I:C/A:C

Temporal Vector: E:U/RL:OF/RC:C

CVSS Score Source: CVE-2021-21703

CVSS v3

Risk Factor: High

Base Score: 8.8

Temporal Score: 7.7

Vector: CVSS:3.0/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H

Temporal Vector: E:U/RL:O/RC:C

CVSS Score Source: CVE-2022-31626

Vulnerability Information

CPE: cpe:/o:redhat:enterprise_linux:7, p-cpe:/a:redhat:enterprise_linux:rh-php73-php, p-cpe:/a:redhat:enterprise_linux:rh-php73-php-bcmath, p-cpe:/a:redhat:enterprise_linux:rh-php73-php-cli, p-cpe:/a:redhat:enterprise_linux:rh-php73-php-common, p-cpe:/a:redhat:enterprise_linux:rh-php73-php-dba, p-cpe:/a:redhat:enterprise_linux:rh-php73-php-dbg, p-cpe:/a:redhat:enterprise_linux:rh-php73-php-devel, p-cpe:/a:redhat:enterprise_linux:rh-php73-php-embedded, p-cpe:/a:redhat:enterprise_linux:rh-php73-php-enchant, p-cpe:/a:redhat:enterprise_linux:rh-php73-php-fpm, p-cpe:/a:redhat:enterprise_linux:rh-php73-php-gd, p-cpe:/a:redhat:enterprise_linux:rh-php73-php-gmp, p-cpe:/a:redhat:enterprise_linux:rh-php73-php-intl, p-cpe:/a:redhat:enterprise_linux:rh-php73-php-json, p-cpe:/a:redhat:enterprise_linux:rh-php73-php-ldap, p-cpe:/a:redhat:enterprise_linux:rh-php73-php-mbstring, p-cpe:/a:redhat:enterprise_linux:rh-php73-php-mysqlnd, p-cpe:/a:redhat:enterprise_linux:rh-php73-php-odbc, p-cpe:/a:redhat:enterprise_linux:rh-php73-php-opcache, p-cpe:/a:redhat:enterprise_linux:rh-php73-php-pdo, p-cpe:/a:redhat:enterprise_linux:rh-php73-php-pgsql, p-cpe:/a:redhat:enterprise_linux:rh-php73-php-process, p-cpe:/a:redhat:enterprise_linux:rh-php73-php-pspell, p-cpe:/a:redhat:enterprise_linux:rh-php73-php-recode, p-cpe:/a:redhat:enterprise_linux:rh-php73-php-snmp, p-cpe:/a:redhat:enterprise_linux:rh-php73-php-soap, p-cpe:/a:redhat:enterprise_linux:rh-php73-php-xml, p-cpe:/a:redhat:enterprise_linux:rh-php73-php-xmlrpc, p-cpe:/a:redhat:enterprise_linux:rh-php73-php-zip

Required KB Items: Host/local_checks_enabled, Host/RedHat/release, Host/RedHat/rpm-list, Host/cpu

Exploit Ease: No known exploits are available

Patch Publication Date: 7/4/2022

Vulnerability Publication Date: 10/25/2021

Reference Information

CVE: CVE-2021-21703, CVE-2021-21707, CVE-2022-31625, CVE-2022-31626

RHSA: 2022:5491

CWE: 20, 119, 120, 824