Debian DLA-3045-1 : php-horde-mime-viewer - LTS security update

medium Nessus Plugin ID 161913

Synopsis

The remote Debian host is missing a security-related update.

Description

The remote Debian 9 host has a package installed that is affected by a vulnerability as referenced in the dla-3045 advisory.

- lib/Horde/Mime/Viewer/Ooo.php in Horde Mime_Viewer before 2.2.4 allows XSS via an OpenOffice document, leading to account takeover in Horde Groupware Webmail Edition. This occurs after XSLT rendering.
(CVE-2022-26874)

Note that Nessus has not tested for this issue but has instead relied only on the application's self-reported version number.

Solution

Upgrade the php-horde-mime-viewer packages.

For Debian 9 Stretch, these problems have been fixed in version 2.2.1-1+deb9u1.

See Also

https://www.debian.org/lts/security/2022/dla-3045

https://security-tracker.debian.org/tracker/CVE-2022-26874

https://packages.debian.org/source/stretch/php-horde-mime-viewer

Plugin Details

Severity: Medium

ID: 161913

File Name: debian_DLA-3045.nasl

Version: 1.2

Type: local

Agent: unix

Published: 6/6/2022

Updated: 6/6/2022

Supported Sensors: Frictionless Assessment Agent, Nessus Agent

Risk Information

VPR

Risk Factor: Low

Score: 3

CVSS v2

Risk Factor: Low

Base Score: 3.5

Temporal Score: 2.6

Vector: CVSS2#AV:N/AC:M/Au:S/C:N/I:P/A:N

Temporal Vector: CVSS2#E:U/RL:OF/RC:C

CVSS Score Source: CVE-2022-26874

CVSS v3

Risk Factor: Medium

Base Score: 5.4

Temporal Score: 4.7

Vector: CVSS:3.0/AV:N/AC:L/PR:L/UI:R/S:C/C:L/I:L/A:N

Temporal Vector: CVSS:3.0/E:U/RL:O/RC:C

Vulnerability Information

CPE: cpe:2.3:o:debian:debian_linux:9.0:*:*:*:*:*:*:*, p-cpe:2.3:a:debian:debian_linux:php-horde-mime-viewer:*:*:*:*:*:*:*

Required KB Items: Host/local_checks_enabled, Host/Debian/release, Host/Debian/dpkg-l

Exploit Ease: No known exploits are available

Patch Publication Date: 6/6/2022

Vulnerability Publication Date: 3/11/2022

Reference Information

CVE: CVE-2022-26874