Apache APISIX < 2.13.1 Information Disclosure

high Nessus Plugin ID 161734

Synopsis

An application installed on the remote host is missing a vendor-supplied update.

Description

The version of Apache APISIX installed on the remote host is prior to 2.13.1. It is, therefore, potentially affected by an information disclosure vulnerability because the jwt-auth plugin has a security issue that leaks the user's secret key because the error message returned from the dependency lua-resty-jwt contains sensitive information.

Note that Nessus has not tested for these issues but has instead relied only on the application's self-reported version number.

Solution

Upgrade to Apache APISIX version 2.13.1 or later.

See Also

https://github.com/apache/apisix/blob/release/2.13/CHANGELOG.md#2131

https://lists.apache.org/thread/6qpfyxogbvn18g9xr8g218jjfjbfsbhr

Plugin Details

Severity: High

ID: 161734

File Name: apache_apisix_2_13_1.nasl

Version: 1.2

Type: remote

Family: Misc.

Published: 6/1/2022

Updated: 6/2/2022

Configuration: Enable paranoid mode

Risk Information

VPR

Risk Factor: Low

Score: 3.6

CVSS v2

Risk Factor: Medium

Base Score: 5

Temporal Score: 3.7

Vector: AV:N/AC:L/Au:N/C:P/I:N/A:N

Temporal Vector: E:U/RL:OF/RC:C

CVSS Score Source: CVE-2022-29266

CVSS v3

Risk Factor: High

Base Score: 7.5

Temporal Score: 6.5

Vector: CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:N

Temporal Vector: E:U/RL:O/RC:C

Vulnerability Information

CPE: cpe:/a:apache:apisix

Required KB Items: installed_sw/Apache APISIX, Settings/ParanoidReport

Exploit Ease: No known exploits are available

Patch Publication Date: 4/15/2022

Vulnerability Publication Date: 4/20/2022

Reference Information

CVE: CVE-2022-29266