CVE-2022-29266

high

Description

In APache APISIX before 3.13.1, the jwt-auth plugin has a security issue that leaks the user's secret key because the error message returned from the dependency lua-resty-jwt contains sensitive information.

References

https://lists.apache.org/thread/6qpfyxogbvn18g9xr8g218jjfjbfsbhr

http://www.openwall.com/lists/oss-security/2022/04/20/1

Details

Source: MITRE

Published: 2022-04-20

Updated: 2022-04-29

Type: CWE-209

Risk Information

CVSS v2

Base Score: 5

Vector: AV:N/AC:L/Au:N/C:P/I:N/A:N

Impact Score: 2.9

Exploitability Score: 10

Severity: MEDIUM

CVSS v3

Base Score: 7.5

Vector: CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:N

Impact Score: 3.6

Exploitability Score: 3.9

Severity: HIGH