SUSE SLES12 / SLES15 Security Update : kernel (Live Patch 15 for SLE 15 SP2) (SUSE-SU-2022:1783-1)

medium Nessus Plugin ID 161431

Synopsis

The remote SUSE host is missing a security update.

Description

The remote SUSE Linux SLES12 / SLES15 host has packages installed that are affected by a vulnerability as referenced in the SUSE-SU-2022:1783-1 advisory.

- A use-after-free vulnerability was found in drm_lease_held in drivers/gpu/drm/drm_lease.c in the Linux kernel due to a race problem. This flaw allows a local user privilege attacker to cause a denial of service (DoS) or a kernel information leak. (CVE-2022-1280)

Note that Nessus has not tested for this issue but has instead relied only on the application's self-reported version number.

Solution

Update the affected kernel-livepatch-5_3_18-24_53_4-default, kernel-livepatch-5_3_18-59_19-default and / or kgraft- patch-4_12_14-122_74-default packages.

See Also

https://bugzilla.suse.com/1198590

http://www.nessus.org/u?f6856268

https://www.suse.com/security/cve/CVE-2022-1280

Plugin Details

Severity: Medium

ID: 161431

File Name: suse_SU-2022-1783-1.nasl

Version: 1.2

Type: local

Agent: unix

Published: 5/22/2022

Updated: 5/22/2022

Supported Sensors: Nessus Agent

Risk Information

VPR

Risk Factor: Medium

Score: 6

CVSS v2

Risk Factor: Low

Base Score: 3.3

Temporal Score: 2.4

Vector: AV:L/AC:M/Au:N/C:P/I:N/A:P

Temporal Vector: E:U/RL:OF/RC:C

CVSS Score Source: CVE-2022-1280

CVSS v3

Risk Factor: Medium

Base Score: 6.3

Temporal Score: 5.5

Vector: CVSS:3.0/AV:L/AC:H/PR:L/UI:N/S:U/C:H/I:N/A:H

Temporal Vector: E:U/RL:O/RC:C

Vulnerability Information

CPE: p-cpe:/a:novell:suse_linux:kernel-livepatch-5_3_18-24_53_4-default, p-cpe:/a:novell:suse_linux:kernel-livepatch-5_3_18-59_19-default, p-cpe:/a:novell:suse_linux:kgraft-patch-4_12_14-122_74-default, cpe:/o:novell:suse_linux:12, cpe:/o:novell:suse_linux:15

Required KB Items: Host/local_checks_enabled, Host/cpu, Host/SuSE/release, Host/SuSE/rpm-list

Exploit Ease: No known exploits are available

Patch Publication Date: 5/20/2022

Vulnerability Publication Date: 4/13/2022

Reference Information

CVE: CVE-2022-1280

SuSE: SUSE-SU-2022:1783-1