SUSE SLED15 / SLES15 Security Update : ImageMagick (SUSE-SU-2022:1762-1)

high Nessus Plugin ID 161423

Synopsis

The remote SUSE host is missing a security update.

Description

The remote SUSE Linux SLED15 / SLES15 host has packages installed that are affected by a vulnerability as referenced in the SUSE-SU-2022:1762-1 advisory.

- ImageMagick 7.1.0-27 is vulnerable to Buffer Overflow. (CVE-2022-28463)

Note that Nessus has not tested for this issue but has instead relied only on the application's self-reported version number.

Solution

Update the affected packages.

See Also

https://bugzilla.suse.com/1197147

https://bugzilla.suse.com/1199350

http://www.nessus.org/u?b8d1a8cc

https://www.suse.com/security/cve/CVE-2022-28463

Plugin Details

Severity: High

ID: 161423

File Name: suse_SU-2022-1762-1.nasl

Version: 1.2

Type: local

Agent: unix

Published: 5/21/2022

Updated: 5/21/2022

Supported Sensors: Nessus Agent

Risk Information

VPR

Risk Factor: Medium

Score: 6.7

CVSS v2

Risk Factor: Medium

Base Score: 6.8

Temporal Score: 5

Vector: AV:N/AC:M/Au:N/C:P/I:P/A:P

Temporal Vector: E:U/RL:OF/RC:C

CVSS Score Source: CVE-2022-28463

CVSS v3

Risk Factor: High

Base Score: 7.8

Temporal Score: 6.8

Vector: CVSS:3.0/AV:L/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H

Temporal Vector: E:U/RL:O/RC:C

Vulnerability Information

CPE: p-cpe:/a:novell:suse_linux:ImageMagick, p-cpe:/a:novell:suse_linux:ImageMagick-config-7-SUSE, p-cpe:/a:novell:suse_linux:ImageMagick-config-7-upstream, p-cpe:/a:novell:suse_linux:ImageMagick-devel, p-cpe:/a:novell:suse_linux:libmagick%2b%2b-7_q16hdri4, p-cpe:/a:novell:suse_linux:libmagick%2b%2b-devel, p-cpe:/a:novell:suse_linux:libMagickCore-7_Q16HDRI6, p-cpe:/a:novell:suse_linux:libMagickWand-7_Q16HDRI6, p-cpe:/a:novell:suse_linux:perl-PerlMagick, cpe:/o:novell:suse_linux:15

Required KB Items: Host/local_checks_enabled, Host/cpu, Host/SuSE/release, Host/SuSE/rpm-list

Exploit Ease: No known exploits are available

Patch Publication Date: 5/20/2022

Vulnerability Publication Date: 5/8/2022

Reference Information

CVE: CVE-2022-28463

SuSE: SUSE-SU-2022:1762-1