AlmaLinux 8 : postgresql:10 (ALSA-2022:1830)

high Nessus Plugin ID 161142

Synopsis

The remote AlmaLinux host is missing a security update.

Description

The remote AlmaLinux 8 host has packages installed that are affected by a vulnerability as referenced in the ALSA-2022:1830 advisory.

- When the server is configured to use trust authentication with a clientcert requirement or to use cert authentication, a man-in-the-middle attacker can inject arbitrary SQL queries when a connection is first established, despite the use of SSL certificate verification and encryption. (CVE-2021-23214)

Note that Nessus has not tested for this issue but has instead relied only on the application's self-reported version number.

Solution

Update the affected packages.

See Also

https://errata.almalinux.org/8/ALSA-2022-1830.html

Plugin Details

Severity: High

ID: 161142

File Name: alma_linux_ALSA-2022-1830.nasl

Version: 1.2

Type: local

Published: 5/12/2022

Updated: 5/12/2022

Risk Information

VPR

Risk Factor: Medium

Score: 6.7

CVSS v2

Risk Factor: Medium

Base Score: 5.1

Temporal Score: 3.8

Vector: AV:N/AC:H/Au:N/C:P/I:P/A:P

Temporal Vector: E:U/RL:OF/RC:C

CVSS Score Source: CVE-2021-23214

CVSS v3

Risk Factor: High

Base Score: 8.1

Temporal Score: 7.1

Vector: CVSS:3.0/AV:N/AC:H/PR:N/UI:N/S:U/C:H/I:H/A:H

Temporal Vector: E:U/RL:O/RC:C

Vulnerability Information

CPE: p-cpe:/a:alma:linux:postgresql, p-cpe:/a:alma:linux:postgresql-contrib, p-cpe:/a:alma:linux:postgresql-docs, p-cpe:/a:alma:linux:postgresql-plperl, p-cpe:/a:alma:linux:postgresql-plpython3, p-cpe:/a:alma:linux:postgresql-pltcl, p-cpe:/a:alma:linux:postgresql-server, p-cpe:/a:alma:linux:postgresql-server-devel, p-cpe:/a:alma:linux:postgresql-static, p-cpe:/a:alma:linux:postgresql-test, p-cpe:/a:alma:linux:postgresql-test-rpm-macros, p-cpe:/a:alma:linux:postgresql-upgrade, p-cpe:/a:alma:linux:postgresql-upgrade-devel, cpe:/o:alma:linux:8

Required KB Items: Host/local_checks_enabled, Host/AlmaLinux/release, Host/AlmaLinux/rpm-list, Host/cpu

Exploit Ease: No known exploits are available

Patch Publication Date: 5/10/2022

Vulnerability Publication Date: 11/11/2021

Reference Information

CVE: CVE-2021-23214

ALSA: 2022:1830

IAVB: 2021-B-0067