AlmaLinux 8 : zsh (ALSA-2022:2120)

high Nessus Plugin ID 161113

Synopsis

The remote AlmaLinux host is missing a security update.

Description

The remote AlmaLinux 8 host has packages installed that are affected by a vulnerability as referenced in the ALSA-2022:2120 advisory.

- In zsh before 5.8.1, an attacker can achieve code execution if they control a command output inside the prompt, as demonstrated by a %F argument. This occurs because of recursive PROMPT_SUBST expansion.
(CVE-2021-45444)

Note that Nessus has not tested for this issue but has instead relied only on the application's self-reported version number.

Solution

Update the affected zsh and / or zsh-html packages.

See Also

https://errata.almalinux.org/8/ALSA-2022-2120.html

Plugin Details

Severity: High

ID: 161113

File Name: alma_linux_ALSA-2022-2120.nasl

Version: 1.2

Type: local

Published: 5/12/2022

Updated: 5/12/2022

Risk Information

VPR

Risk Factor: Medium

Score: 6.7

CVSS v2

Risk Factor: Medium

Base Score: 5.1

Temporal Score: 3.8

Vector: AV:N/AC:H/Au:N/C:P/I:P/A:P

Temporal Vector: E:U/RL:OF/RC:C

CVSS Score Source: CVE-2021-45444

CVSS v3

Risk Factor: High

Base Score: 7.8

Temporal Score: 6.8

Vector: CVSS:3.0/AV:L/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H

Temporal Vector: E:U/RL:O/RC:C

Vulnerability Information

CPE: p-cpe:/a:alma:linux:zsh, p-cpe:/a:alma:linux:zsh-html, cpe:/o:alma:linux:8

Required KB Items: Host/local_checks_enabled, Host/AlmaLinux/release, Host/AlmaLinux/rpm-list, Host/cpu

Exploit Ease: No known exploits are available

Patch Publication Date: 5/10/2022

Vulnerability Publication Date: 2/12/2022

Reference Information

CVE: CVE-2021-45444

ALSA: 2022:2120