AlmaLinux 8 : maven:3.5 (ALSA-2022:1861)

medium Nessus Plugin ID 161099

Synopsis

The remote AlmaLinux host is missing a security update.

Description

The remote AlmaLinux 8 host has packages installed that are affected by a vulnerability as referenced in the ALSA-2022:1861 advisory.

- Apache HttpClient versions prior to version 4.5.13 and 5.0.3 can misinterpret malformed authority component in request URIs passed to the library as java.net.URI object and pick the wrong target host for request execution. (CVE-2020-13956)

Note that Nessus has not tested for this issue but has instead relied only on the application's self-reported version number.

Solution

Update the affected packages.

See Also

https://errata.almalinux.org/8/ALSA-2022-1861.html

Plugin Details

Severity: Medium

ID: 161099

File Name: alma_linux_ALSA-2022-1861.nasl

Version: 1.2

Type: local

Published: 5/12/2022

Updated: 5/12/2022

Risk Information

VPR

Risk Factor: Low

Score: 2.2

CVSS v2

Risk Factor: Medium

Base Score: 5

Temporal Score: 3.7

Vector: AV:N/AC:L/Au:N/C:N/I:P/A:N

Temporal Vector: E:U/RL:OF/RC:C

CVSS Score Source: CVE-2020-13956

CVSS v3

Risk Factor: Medium

Base Score: 5.3

Temporal Score: 4.6

Vector: CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:L/A:N

Temporal Vector: E:U/RL:O/RC:C

Vulnerability Information

CPE: p-cpe:/a:alma:linux:aopalliance, p-cpe:/a:alma:linux:apache-commons-cli, p-cpe:/a:alma:linux:apache-commons-codec, p-cpe:/a:alma:linux:apache-commons-io, p-cpe:/a:alma:linux:apache-commons-lang3, p-cpe:/a:alma:linux:apache-commons-logging, p-cpe:/a:alma:linux:atinject, p-cpe:/a:alma:linux:cdi-api, p-cpe:/a:alma:linux:geronimo-annotation, p-cpe:/a:alma:linux:glassfish-el-api, p-cpe:/a:alma:linux:google-guice, p-cpe:/a:alma:linux:guava20, p-cpe:/a:alma:linux:hawtjni-runtime, p-cpe:/a:alma:linux:httpcomponents-client, p-cpe:/a:alma:linux:httpcomponents-core, p-cpe:/a:alma:linux:jansi, p-cpe:/a:alma:linux:jansi-native, p-cpe:/a:alma:linux:jboss-interceptors-1.2-api, p-cpe:/a:alma:linux:jcl-over-slf4j, p-cpe:/a:alma:linux:jsoup, p-cpe:/a:alma:linux:maven, p-cpe:/a:alma:linux:maven-lib, p-cpe:/a:alma:linux:maven-resolver-api, p-cpe:/a:alma:linux:maven-resolver-connector-basic, p-cpe:/a:alma:linux:maven-resolver-impl, p-cpe:/a:alma:linux:maven-resolver-spi, p-cpe:/a:alma:linux:maven-resolver-transport-wagon, p-cpe:/a:alma:linux:maven-resolver-util, p-cpe:/a:alma:linux:maven-shared-utils, p-cpe:/a:alma:linux:maven-wagon-file, p-cpe:/a:alma:linux:maven-wagon-http, p-cpe:/a:alma:linux:maven-wagon-http-shared, p-cpe:/a:alma:linux:maven-wagon-provider-api, p-cpe:/a:alma:linux:plexus-cipher, p-cpe:/a:alma:linux:plexus-classworlds, p-cpe:/a:alma:linux:plexus-containers-component-annotations, p-cpe:/a:alma:linux:plexus-interpolation, p-cpe:/a:alma:linux:plexus-sec-dispatcher, p-cpe:/a:alma:linux:plexus-utils, p-cpe:/a:alma:linux:sisu-inject, p-cpe:/a:alma:linux:sisu-plexus, p-cpe:/a:alma:linux:slf4j, cpe:/o:alma:linux:8

Required KB Items: Host/local_checks_enabled, Host/AlmaLinux/release, Host/AlmaLinux/rpm-list, Host/cpu

Exploit Ease: No known exploits are available

Patch Publication Date: 5/10/2022

Vulnerability Publication Date: 12/2/2020

Reference Information

CVE: CVE-2020-13956

ALSA: 2022:1861