NewStart CGSL MAIN 6.02 : poppler Vulnerability (NS-SA-2022-0061)

high Nessus Plugin ID 160852

Synopsis

The remote NewStart CGSL host is affected by a vulnerability.

Description

The remote NewStart CGSL host, running version MAIN 6.02, has poppler packages installed that are affected by a vulnerability:

- A flaw was found in Poppler in the way certain PDF files were converted into HTML. A remote attacker could exploit this flaw by providing a malicious PDF file that, when processed by the 'pdftohtml' program, would crash the application causing a denial of service. (CVE-2020-27778)

Note that Nessus has not tested for this issue but has instead relied only on the application's self-reported version number.

Solution

Upgrade the vulnerable CGSL poppler packages. Note that updated packages may not be available yet. Please contact ZTE for more information.

See Also

http://security.gd-linux.com/notice/NS-SA-2022-0061

http://security.gd-linux.com/info/CVE-2020-27778

Plugin Details

Severity: High

ID: 160852

File Name: newstart_cgsl_NS-SA-2022-0061_poppler.nasl

Version: 1.2

Type: local

Published: 5/10/2022

Updated: 5/10/2022

Risk Information

VPR

Risk Factor: Low

Score: 3.6

CVSS v2

Risk Factor: Medium

Base Score: 5

Temporal Score: 3.7

Vector: AV:N/AC:L/Au:N/C:N/I:N/A:P

Temporal Vector: E:U/RL:OF/RC:C

CVSS Score Source: CVE-2020-27778

CVSS v3

Risk Factor: High

Base Score: 7.5

Temporal Score: 6.5

Vector: CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H

Temporal Vector: E:U/RL:O/RC:C

Vulnerability Information

CPE: p-cpe:/a:zte:cgsl_main:poppler, p-cpe:/a:zte:cgsl_main:poppler-cpp, p-cpe:/a:zte:cgsl_main:poppler-cpp-debuginfo, p-cpe:/a:zte:cgsl_main:poppler-cpp-devel, p-cpe:/a:zte:cgsl_main:poppler-debuginfo, p-cpe:/a:zte:cgsl_main:poppler-debugsource, p-cpe:/a:zte:cgsl_main:poppler-devel, p-cpe:/a:zte:cgsl_main:poppler-glib, p-cpe:/a:zte:cgsl_main:poppler-glib-debuginfo, p-cpe:/a:zte:cgsl_main:poppler-glib-devel, p-cpe:/a:zte:cgsl_main:poppler-glib-doc, p-cpe:/a:zte:cgsl_main:poppler-qt5, p-cpe:/a:zte:cgsl_main:poppler-qt5-debuginfo, p-cpe:/a:zte:cgsl_main:poppler-qt5-devel, p-cpe:/a:zte:cgsl_main:poppler-utils, p-cpe:/a:zte:cgsl_main:poppler-utils-debuginfo, cpe:/o:zte:cgsl_main:6

Required KB Items: Host/local_checks_enabled, Host/ZTE-CGSL/release, Host/ZTE-CGSL/rpm-list, Host/cpu

Exploit Ease: No known exploits are available

Patch Publication Date: 5/8/2022

Vulnerability Publication Date: 12/3/2020

Reference Information

CVE: CVE-2020-27778