NewStart CGSL CORE 5.05 / MAIN 5.05 : ipa Vulnerability (NS-SA-2022-0037)

medium Nessus Plugin ID 160851

Synopsis

The remote NewStart CGSL host is affected by a vulnerability.

Description

The remote NewStart CGSL host, running version CORE 5.05 / MAIN 5.05, has ipa packages installed that are affected by a vulnerability:

- In jQuery versions greater than or equal to 1.0.3 and before 3.5.0, passing HTML containing <option> elements from untrusted sources - even after sanitizing it - to one of jQuery's DOM manipulation methods (i.e. .html(), .append(), and others) may execute untrusted code. This problem is patched in jQuery 3.5.0.
(CVE-2020-11023)

Note that Nessus has not tested for this issue but has instead relied only on the application's self-reported version number.

Solution

Upgrade the vulnerable CGSL ipa packages. Note that updated packages may not be available yet. Please contact ZTE for more information.

See Also

http://security.gd-linux.com/notice/NS-SA-2022-0037

http://security.gd-linux.com/info/CVE-2020-11023

Plugin Details

Severity: Medium

ID: 160851

File Name: newstart_cgsl_NS-SA-2022-0037_ipa.nasl

Version: 1.3

Type: local

Published: 5/10/2022

Updated: 5/11/2022

Risk Information

VPR

Risk Factor: Medium

Score: 5.7

CVSS v2

Risk Factor: Medium

Base Score: 4.3

Temporal Score: 3.4

Vector: AV:N/AC:M/Au:N/C:N/I:P/A:N

Temporal Vector: E:POC/RL:OF/RC:C

CVSS Score Source: CVE-2020-11023

CVSS v3

Risk Factor: Medium

Base Score: 6.1

Temporal Score: 5.5

Vector: CVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N

Temporal Vector: E:P/RL:O/RC:C

Vulnerability Information

CPE: p-cpe:/a:zte:cgsl_core:ipa-client, p-cpe:/a:zte:cgsl_core:ipa-client-common, p-cpe:/a:zte:cgsl_core:ipa-common, p-cpe:/a:zte:cgsl_core:ipa-debuginfo, p-cpe:/a:zte:cgsl_core:ipa-python-compat, p-cpe:/a:zte:cgsl_core:ipa-server, p-cpe:/a:zte:cgsl_core:ipa-server-common, p-cpe:/a:zte:cgsl_core:ipa-server-dns, p-cpe:/a:zte:cgsl_core:ipa-server-trust-ad, p-cpe:/a:zte:cgsl_core:python2-ipaclient, p-cpe:/a:zte:cgsl_core:python2-ipalib, p-cpe:/a:zte:cgsl_core:python2-ipaserver, p-cpe:/a:zte:cgsl_main:ipa-client, p-cpe:/a:zte:cgsl_main:ipa-client-common, p-cpe:/a:zte:cgsl_main:ipa-common, p-cpe:/a:zte:cgsl_main:ipa-debuginfo, p-cpe:/a:zte:cgsl_main:ipa-python-compat, p-cpe:/a:zte:cgsl_main:ipa-server, p-cpe:/a:zte:cgsl_main:ipa-server-common, p-cpe:/a:zte:cgsl_main:ipa-server-dns, p-cpe:/a:zte:cgsl_main:ipa-server-trust-ad, p-cpe:/a:zte:cgsl_main:python2-ipaclient, p-cpe:/a:zte:cgsl_main:python2-ipalib, p-cpe:/a:zte:cgsl_main:python2-ipaserver, cpe:/o:zte:cgsl_core:5, cpe:/o:zte:cgsl_main:5

Required KB Items: Host/local_checks_enabled, Host/ZTE-CGSL/release, Host/ZTE-CGSL/rpm-list, Host/cpu

Exploit Available: true

Exploit Ease: Exploits are available

Patch Publication Date: 5/8/2022

Vulnerability Publication Date: 4/29/2020

Reference Information

CVE: CVE-2020-11023

IAVB: 2020-B-0030

IAVA: 2022-A-0029, 2021-A-0194-S