NewStart CGSL CORE 5.05 / MAIN 5.05 : 389-ds-base Vulnerability (NS-SA-2022-0026)

medium Nessus Plugin ID 160825

Synopsis

The remote NewStart CGSL host is affected by a vulnerability.

Description

The remote NewStart CGSL host, running version CORE 5.05 / MAIN 5.05, has 389-ds-base packages installed that are affected by a vulnerability:

- When binding against a DN during authentication, the reply from 389-ds-base will be different whether the DN exists or not. This can be used by an unauthenticated attacker to check the existence of an entry in the LDAP database. (CVE-2020-35518)

Note that Nessus has not tested for this issue but has instead relied only on the application's self-reported version number.

Solution

Upgrade the vulnerable CGSL 389-ds-base packages. Note that updated packages may not be available yet. Please contact ZTE for more information.

See Also

http://security.gd-linux.com/notice/NS-SA-2022-0026

http://security.gd-linux.com/info/CVE-2020-35518

Plugin Details

Severity: Medium

ID: 160825

File Name: newstart_cgsl_NS-SA-2022-0026_389-ds-base.nasl

Version: 1.2

Type: local

Published: 5/10/2022

Updated: 5/10/2022

Risk Information

VPR

Risk Factor: Low

Score: 1.4

CVSS v2

Risk Factor: Medium

Base Score: 5

Temporal Score: 3.7

Vector: AV:N/AC:L/Au:N/C:P/I:N/A:N

Temporal Vector: E:U/RL:OF/RC:C

CVSS Score Source: CVE-2020-35518

CVSS v3

Risk Factor: Medium

Base Score: 5.3

Temporal Score: 4.6

Vector: CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:N/A:N

Temporal Vector: E:U/RL:O/RC:C

Vulnerability Information

CPE: p-cpe:/a:zte:cgsl_core:389-ds-base, p-cpe:/a:zte:cgsl_core:389-ds-base-debuginfo, p-cpe:/a:zte:cgsl_core:389-ds-base-devel, p-cpe:/a:zte:cgsl_core:389-ds-base-libs, p-cpe:/a:zte:cgsl_core:389-ds-base-snmp, p-cpe:/a:zte:cgsl_core:389-ds-base-tests, p-cpe:/a:zte:cgsl_main:389-ds-base, p-cpe:/a:zte:cgsl_main:389-ds-base-debuginfo, p-cpe:/a:zte:cgsl_main:389-ds-base-devel, p-cpe:/a:zte:cgsl_main:389-ds-base-libs, p-cpe:/a:zte:cgsl_main:389-ds-base-snmp, p-cpe:/a:zte:cgsl_main:389-ds-base-tests, cpe:/o:zte:cgsl_core:5, cpe:/o:zte:cgsl_main:5

Required KB Items: Host/local_checks_enabled, Host/ZTE-CGSL/release, Host/ZTE-CGSL/rpm-list, Host/cpu

Exploit Ease: No known exploits are available

Patch Publication Date: 5/8/2022

Vulnerability Publication Date: 2/26/2021

Reference Information

CVE: CVE-2020-35518