NewStart CGSL CORE 5.05 / MAIN 5.05 : lasso Vulnerability (NS-SA-2022-0046)

high Nessus Plugin ID 160822

Synopsis

The remote NewStart CGSL host is affected by a vulnerability.

Description

The remote NewStart CGSL host, running version CORE 5.05 / MAIN 5.05, has lasso packages installed that are affected by a vulnerability:

- Lasso all versions prior to 2.7.0 has improper verification of a cryptographic signature. (CVE-2021-28091)

Note that Nessus has not tested for this issue but has instead relied only on the application's self-reported version number.

Solution

Upgrade the vulnerable CGSL lasso packages. Note that updated packages may not be available yet. Please contact ZTE for more information.

See Also

http://security.gd-linux.com/notice/NS-SA-2022-0046

http://security.gd-linux.com/info/CVE-2021-28091

Plugin Details

Severity: High

ID: 160822

File Name: newstart_cgsl_NS-SA-2022-0046_lasso.nasl

Version: 1.2

Type: local

Published: 5/9/2022

Updated: 5/9/2022

Risk Information

VPR

Risk Factor: Low

Score: 3.6

CVSS v2

Risk Factor: Medium

Base Score: 5

Temporal Score: 3.7

Vector: AV:N/AC:L/Au:N/C:N/I:P/A:N

Temporal Vector: E:U/RL:OF/RC:C

CVSS Score Source: CVE-2021-28091

CVSS v3

Risk Factor: High

Base Score: 7.5

Temporal Score: 6.5

Vector: CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:H/A:N

Temporal Vector: E:U/RL:O/RC:C

Vulnerability Information

CPE: p-cpe:/a:zte:cgsl_core:lasso, p-cpe:/a:zte:cgsl_core:lasso-debuginfo, p-cpe:/a:zte:cgsl_core:lasso-devel, p-cpe:/a:zte:cgsl_core:lasso-python, p-cpe:/a:zte:cgsl_main:lasso, p-cpe:/a:zte:cgsl_main:lasso-debuginfo, p-cpe:/a:zte:cgsl_main:lasso-devel, p-cpe:/a:zte:cgsl_main:lasso-python, cpe:/o:zte:cgsl_core:5, cpe:/o:zte:cgsl_main:5

Required KB Items: Host/local_checks_enabled, Host/ZTE-CGSL/release, Host/ZTE-CGSL/rpm-list, Host/cpu

Exploit Ease: No known exploits are available

Patch Publication Date: 5/8/2022

Vulnerability Publication Date: 6/2/2021

Reference Information

CVE: CVE-2021-28091