NewStart CGSL CORE 5.04 / MAIN 5.04 : httpd Vulnerability (NS-SA-2022-0016)

critical Nessus Plugin ID 160821

Synopsis

The remote NewStart CGSL host is affected by a vulnerability.

Description

The remote NewStart CGSL host, running version CORE 5.04 / MAIN 5.04, has httpd packages installed that are affected by a vulnerability:

- A crafted request uri-path can cause mod_proxy to forward the request to an origin server choosen by the remote user. This issue affects Apache HTTP Server 2.4.48 and earlier. (CVE-2021-40438)

Note that Nessus has not tested for this issue but has instead relied only on the application's self-reported version number.

Solution

Upgrade the vulnerable CGSL httpd packages. Note that updated packages may not be available yet. Please contact ZTE for more information.

See Also

http://security.gd-linux.com/notice/NS-SA-2022-0016

http://security.gd-linux.com/info/CVE-2021-40438

Plugin Details

Severity: Critical

ID: 160821

File Name: newstart_cgsl_NS-SA-2022-0016_httpd.nasl

Version: 1.3

Type: local

Published: 5/9/2022

Updated: 5/17/2022

Risk Information

VPR

Risk Factor: High

Score: 8.1

CVSS v2

Risk Factor: Medium

Base Score: 6.8

Temporal Score: 5.9

Vector: AV:N/AC:M/Au:N/C:P/I:P/A:P

Temporal Vector: E:H/RL:OF/RC:C

CVSS Score Source: CVE-2021-40438

CVSS v3

Risk Factor: Critical

Base Score: 9

Temporal Score: 8.6

Vector: CVSS:3.0/AV:N/AC:H/PR:N/UI:N/S:C/C:H/I:H/A:H

Temporal Vector: E:H/RL:O/RC:C

Vulnerability Information

CPE: p-cpe:/a:zte:cgsl_core:httpd, p-cpe:/a:zte:cgsl_core:httpd-debuginfo, p-cpe:/a:zte:cgsl_core:httpd-devel, p-cpe:/a:zte:cgsl_core:httpd-manual, p-cpe:/a:zte:cgsl_core:httpd-tools, p-cpe:/a:zte:cgsl_core:mod_ldap, p-cpe:/a:zte:cgsl_core:mod_proxy_html, p-cpe:/a:zte:cgsl_core:mod_session, p-cpe:/a:zte:cgsl_core:mod_ssl, p-cpe:/a:zte:cgsl_main:httpd, p-cpe:/a:zte:cgsl_main:httpd-debuginfo, p-cpe:/a:zte:cgsl_main:httpd-devel, p-cpe:/a:zte:cgsl_main:httpd-manual, p-cpe:/a:zte:cgsl_main:httpd-tools, p-cpe:/a:zte:cgsl_main:mod_ldap, p-cpe:/a:zte:cgsl_main:mod_proxy_html, p-cpe:/a:zte:cgsl_main:mod_session, p-cpe:/a:zte:cgsl_main:mod_ssl, cpe:/o:zte:cgsl_core:5, cpe:/o:zte:cgsl_main:5

Required KB Items: Host/local_checks_enabled, Host/ZTE-CGSL/release, Host/ZTE-CGSL/rpm-list, Host/cpu

Exploit Available: true

Exploit Ease: Exploits are available

Patch Publication Date: 5/8/2022

Vulnerability Publication Date: 9/16/2021

CISA Known Exploited Dates: 12/15/2021

Reference Information

CVE: CVE-2021-40438

IAVA: 2022-A-0029, 2022-A-0165, 2021-A-0440-S