NewStart CGSL MAIN 6.02 : NetworkManager Vulnerability (NS-SA-2022-0072)

medium Nessus Plugin ID 160819

Synopsis

The remote NewStart CGSL host is affected by a vulnerability.

Description

The remote NewStart CGSL host, running version MAIN 6.02, has NetworkManager packages installed that are affected by a vulnerability:

- An exploitable denial-of-service vulnerability exists in Systemd 245. A specially crafted DHCP FORCERENEW packet can cause a server running the DHCP client to be vulnerable to a DHCP ACK spoofing attack. An attacker can forge a pair of FORCERENEW and DCHP ACK packets to reconfigure the server. (CVE-2020-13529)

Note that Nessus has not tested for this issue but has instead relied only on the application's self-reported version number.

Solution

Upgrade the vulnerable CGSL NetworkManager packages. Note that updated packages may not be available yet. Please contact ZTE for more information.

See Also

http://security.gd-linux.com/notice/NS-SA-2022-0072

http://security.gd-linux.com/info/CVE-2020-13529

Plugin Details

Severity: Medium

ID: 160819

File Name: newstart_cgsl_NS-SA-2022-0072_NetworkManager.nasl

Version: 1.2

Type: local

Published: 5/9/2022

Updated: 5/9/2022

Risk Information

VPR

Risk Factor: Medium

Score: 4.4

CVSS v2

Risk Factor: Low

Base Score: 2.9

Temporal Score: 2.1

Vector: AV:A/AC:M/Au:N/C:N/I:N/A:P

Temporal Vector: E:U/RL:OF/RC:C

CVSS Score Source: CVE-2020-13529

CVSS v3

Risk Factor: Medium

Base Score: 6.1

Temporal Score: 5.3

Vector: CVSS:3.0/AV:A/AC:H/PR:N/UI:N/S:C/C:N/I:N/A:H

Temporal Vector: E:U/RL:O/RC:C

Vulnerability Information

CPE: p-cpe:/a:zte:cgsl_main:NetworkManager, p-cpe:/a:zte:cgsl_main:NetworkManager-adsl, p-cpe:/a:zte:cgsl_main:NetworkManager-adsl-debuginfo, p-cpe:/a:zte:cgsl_main:NetworkManager-bluetooth, p-cpe:/a:zte:cgsl_main:NetworkManager-bluetooth-debuginfo, p-cpe:/a:zte:cgsl_main:NetworkManager-cloud-setup, p-cpe:/a:zte:cgsl_main:NetworkManager-cloud-setup-debuginfo, p-cpe:/a:zte:cgsl_main:NetworkManager-config-connectivity-redhat, p-cpe:/a:zte:cgsl_main:NetworkManager-config-server, p-cpe:/a:zte:cgsl_main:NetworkManager-debuginfo, p-cpe:/a:zte:cgsl_main:NetworkManager-debugsource, p-cpe:/a:zte:cgsl_main:NetworkManager-dispatcher-routing-rules, p-cpe:/a:zte:cgsl_main:NetworkManager-libnm, p-cpe:/a:zte:cgsl_main:NetworkManager-libnm-debuginfo, p-cpe:/a:zte:cgsl_main:NetworkManager-libnm-devel, p-cpe:/a:zte:cgsl_main:NetworkManager-ovs, p-cpe:/a:zte:cgsl_main:NetworkManager-ovs-debuginfo, p-cpe:/a:zte:cgsl_main:NetworkManager-ppp, p-cpe:/a:zte:cgsl_main:NetworkManager-ppp-debuginfo, p-cpe:/a:zte:cgsl_main:NetworkManager-team, p-cpe:/a:zte:cgsl_main:NetworkManager-team-debuginfo, p-cpe:/a:zte:cgsl_main:NetworkManager-tui, p-cpe:/a:zte:cgsl_main:NetworkManager-tui-debuginfo, p-cpe:/a:zte:cgsl_main:NetworkManager-wifi, p-cpe:/a:zte:cgsl_main:NetworkManager-wifi-debuginfo, p-cpe:/a:zte:cgsl_main:NetworkManager-wwan, p-cpe:/a:zte:cgsl_main:NetworkManager-wwan-debuginfo, cpe:/o:zte:cgsl_main:6

Required KB Items: Host/local_checks_enabled, Host/ZTE-CGSL/release, Host/ZTE-CGSL/rpm-list, Host/cpu

Exploit Ease: No known exploits are available

Patch Publication Date: 5/8/2022

Vulnerability Publication Date: 5/10/2021

Reference Information

CVE: CVE-2020-13529