NewStart CGSL CORE 5.05 / MAIN 5.05 : pki-core Multiple Vulnerabilities (NS-SA-2022-0029)

high Nessus Plugin ID 160757

Synopsis

The remote NewStart CGSL host is affected by multiple vulnerabilities.

Description

The remote NewStart CGSL host, running version CORE 5.05 / MAIN 5.05, has pki-core packages installed that are affected by multiple vulnerabilities:

- A Reflected Cross Site Scripting flaw was found in all pki-core 10.x.x versions module from the pki-core server due to the CA Agent Service not properly sanitizing the certificate request page. An attacker could inject a specially crafted value that will be executed on the victim's browser. (CVE-2019-10146)

- A vulnerability was found in all pki-core 10.x.x versions, where the Key Recovery Authority (KRA) Agent Service did not properly sanitize recovery request search page, enabling a Reflected Cross Site Scripting (XSS) vulnerability. An attacker could trick an authenticated victim into executing specially crafted Javascript code. (CVE-2019-10179)

- A Reflected Cross Site Scripting vulnerability was found in all pki-core 10.x.x versions, where the pki-ca module from the pki-core server. This flaw is caused by missing sanitization of the GET URL parameters. An attacker could abuse this flaw to trick an authenticated user into clicking a specially crafted link which can execute arbitrary code when viewed in a browser. (CVE-2019-10221)

- A flaw was found in the Key Recovery Authority (KRA) Agent Service in pki-core 10.10.5 where it did not properly sanitize the recovery ID during a key recovery request, enabling a reflected cross-site scripting (XSS) vulnerability. An attacker could trick an authenticated victim into executing specially crafted Javascript code. (CVE-2020-1721)

- A flaw was found in pki-core 10.9.0. A specially crafted POST request can be used to reflect a DOM-based cross-site scripting (XSS) attack to inject code into the search query form which can get automatically executed. The highest threat from this vulnerability is to data integrity. (CVE-2020-25715)

- A flaw was found in pki-core. An attacker who has successfully compromised a key could use this flaw to renew the corresponding certificate over and over again, as long as it is not explicitly revoked. The highest threat from this vulnerability is to data confidentiality and integrity. (CVE-2021-20179)

Note that Nessus has not tested for these issues but has instead relied only on the application's self-reported version number.

Solution

Upgrade the vulnerable CGSL pki-core packages. Note that updated packages may not be available yet. Please contact ZTE for more information.

See Also

http://security.gd-linux.com/notice/NS-SA-2022-0029

http://security.gd-linux.com/info/CVE-2019-10146

http://security.gd-linux.com/info/CVE-2019-10179

http://security.gd-linux.com/info/CVE-2019-10221

http://security.gd-linux.com/info/CVE-2020-1721

http://security.gd-linux.com/info/CVE-2020-25715

http://security.gd-linux.com/info/CVE-2021-20179

Plugin Details

Severity: High

ID: 160757

File Name: newstart_cgsl_NS-SA-2022-0029_pki-core.nasl

Version: 1.2

Type: local

Published: 5/9/2022

Updated: 5/9/2022

Risk Information

VPR

Risk Factor: Medium

Score: 6

CVSS v2

Risk Factor: Medium

Base Score: 5.5

Temporal Score: 4.1

Vector: AV:N/AC:L/Au:S/C:P/I:P/A:N

Temporal Vector: E:U/RL:OF/RC:C

CVSS Score Source: CVE-2021-20179

CVSS v3

Risk Factor: High

Base Score: 8.1

Temporal Score: 7.1

Vector: CVSS:3.0/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:N

Temporal Vector: E:U/RL:O/RC:C

Vulnerability Information

CPE: p-cpe:/a:zte:cgsl_core:pki-base, p-cpe:/a:zte:cgsl_core:pki-base-java, p-cpe:/a:zte:cgsl_core:pki-ca, p-cpe:/a:zte:cgsl_core:pki-core-debuginfo, p-cpe:/a:zte:cgsl_core:pki-javadoc, p-cpe:/a:zte:cgsl_core:pki-kra, p-cpe:/a:zte:cgsl_core:pki-server, p-cpe:/a:zte:cgsl_core:pki-symkey, p-cpe:/a:zte:cgsl_core:pki-tools, p-cpe:/a:zte:cgsl_main:pki-base, p-cpe:/a:zte:cgsl_main:pki-base-java, p-cpe:/a:zte:cgsl_main:pki-ca, p-cpe:/a:zte:cgsl_main:pki-core-debuginfo, p-cpe:/a:zte:cgsl_main:pki-javadoc, p-cpe:/a:zte:cgsl_main:pki-kra, p-cpe:/a:zte:cgsl_main:pki-server, p-cpe:/a:zte:cgsl_main:pki-symkey, p-cpe:/a:zte:cgsl_main:pki-tools, cpe:/o:zte:cgsl_core:5, cpe:/o:zte:cgsl_main:5

Required KB Items: Host/local_checks_enabled, Host/ZTE-CGSL/release, Host/ZTE-CGSL/rpm-list, Host/cpu

Exploit Ease: No known exploits are available

Patch Publication Date: 5/8/2022

Vulnerability Publication Date: 3/18/2020

Reference Information

CVE: CVE-2019-10146, CVE-2019-10179, CVE-2019-10221, CVE-2020-1721, CVE-2020-25715, CVE-2021-20179