NewStart CGSL MAIN 6.02 : linux-firmware Multiple Vulnerabilities (NS-SA-2022-0063)

high Nessus Plugin ID 160744

Synopsis

The remote NewStart CGSL host is affected by multiple vulnerabilities.

Description

The remote NewStart CGSL host, running version MAIN 6.02, has linux-firmware packages installed that are affected by multiple vulnerabilities:

- Integer overflow in the firmware for some Intel(R) Graphics Drivers for Windows * before version 26.20.100.7212 and before Linux kernel version 5.5 may allow a privileged user to potentially enable an escalation of privilege via local access. (CVE-2020-12362)

- Improper input validation in some Intel(R) Graphics Drivers for Windows* before version 26.20.100.7212 and before Linux kernel version 5.5 may allow a privileged user to potentially enable a denial of service via local access. (CVE-2020-12363)

- Null pointer reference in some Intel(R) Graphics Drivers for Windows* before version 26.20.100.7212 and before version Linux kernel version 5.5 may allow a privileged user to potentially enable a denial of service via local access. (CVE-2020-12364)

Note that Nessus has not tested for these issues but has instead relied only on the application's self-reported version number.

Solution

Upgrade the vulnerable CGSL linux-firmware packages. Note that updated packages may not be available yet. Please contact ZTE for more information.

See Also

http://security.gd-linux.com/notice/NS-SA-2022-0063

http://security.gd-linux.com/info/CVE-2020-12362

http://security.gd-linux.com/info/CVE-2020-12363

http://security.gd-linux.com/info/CVE-2020-12364

Plugin Details

Severity: High

ID: 160744

File Name: newstart_cgsl_NS-SA-2022-0063_linux-firmware.nasl

Version: 1.2

Type: local

Published: 5/9/2022

Updated: 5/9/2022

Risk Information

VPR

Risk Factor: Medium

Score: 5.9

CVSS v2

Risk Factor: Medium

Base Score: 4.6

Temporal Score: 3.4

Vector: AV:L/AC:L/Au:N/C:P/I:P/A:P

Temporal Vector: E:U/RL:OF/RC:C

CVSS Score Source: CVE-2020-12362

CVSS v3

Risk Factor: High

Base Score: 7.8

Temporal Score: 6.8

Vector: CVSS:3.0/AV:L/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H

Temporal Vector: E:U/RL:O/RC:C

Vulnerability Information

CPE: p-cpe:/a:zte:cgsl_main:iwl100-firmware, p-cpe:/a:zte:cgsl_main:iwl1000-firmware, p-cpe:/a:zte:cgsl_main:iwl105-firmware, p-cpe:/a:zte:cgsl_main:iwl135-firmware, p-cpe:/a:zte:cgsl_main:iwl2000-firmware, p-cpe:/a:zte:cgsl_main:iwl2030-firmware, p-cpe:/a:zte:cgsl_main:iwl3160-firmware, p-cpe:/a:zte:cgsl_main:iwl3945-firmware, p-cpe:/a:zte:cgsl_main:iwl4965-firmware, p-cpe:/a:zte:cgsl_main:iwl5000-firmware, p-cpe:/a:zte:cgsl_main:iwl5150-firmware, p-cpe:/a:zte:cgsl_main:iwl6000-firmware, p-cpe:/a:zte:cgsl_main:iwl6000g2a-firmware, p-cpe:/a:zte:cgsl_main:iwl6000g2b-firmware, p-cpe:/a:zte:cgsl_main:iwl6050-firmware, p-cpe:/a:zte:cgsl_main:iwl7260-firmware, p-cpe:/a:zte:cgsl_main:libertas-sd8686-firmware, p-cpe:/a:zte:cgsl_main:libertas-sd8787-firmware, p-cpe:/a:zte:cgsl_main:libertas-usb8388-firmware, p-cpe:/a:zte:cgsl_main:libertas-usb8388-olpc-firmware, p-cpe:/a:zte:cgsl_main:linux-firmware, cpe:/o:zte:cgsl_main:6

Required KB Items: Host/local_checks_enabled, Host/ZTE-CGSL/release, Host/ZTE-CGSL/rpm-list, Host/cpu

Exploit Ease: No known exploits are available

Patch Publication Date: 5/8/2022

Vulnerability Publication Date: 2/17/2021

Reference Information

CVE: CVE-2020-12362, CVE-2020-12363, CVE-2020-12364