Ubuntu 16.04 LTS : Libcroco vulnerabilities (USN-5389-1)

high Nessus Plugin ID 160213

Synopsis

The remote Ubuntu host is missing one or more security updates.

Description

The remote Ubuntu 16.04 LTS host has packages installed that are affected by multiple vulnerabilities as referenced in the USN-5389-1 advisory.

- The cr_input_new_from_uri function in cr-input.c in libcroco 0.6.11 and 0.6.12 allows remote attackers to cause a denial of service (heap-based buffer over-read) via a crafted CSS file. (CVE-2017-7960)

- The cr_tknzr_parse_comment function in cr-tknzr.c in libcroco 0.6.12 allows remote attackers to cause a denial of service (memory allocation error) via a crafted CSS file. (CVE-2017-8834)

- The cr_parser_parse_selector_core function in cr-parser.c in libcroco 0.6.12 allows remote attackers to cause a denial of service (infinite loop and CPU consumption) via a crafted CSS file. (CVE-2017-8871)

- libcroco through 0.6.13 has excessive recursion in cr_parser_parse_any_core in cr-parser.c, leading to stack consumption. (CVE-2020-12825)

Note that Nessus has not tested for these issues but has instead relied only on the application's self-reported version number.

Solution

Update the affected libcroco-tools, libcroco3 and / or libcroco3-dev packages.

See Also

https://ubuntu.com/security/notices/USN-5389-1

Plugin Details

Severity: High

ID: 160213

File Name: ubuntu_USN-5389-1.nasl

Version: 1.3

Type: local

Agent: unix

Published: 4/26/2022

Updated: 4/27/2022

Supported Sensors: Agentless Assessment, Frictionless Assessment Agent, Frictionless Assessment AWS, Frictionless Assessment Azure, Nessus Agent

Risk Information

VPR

Risk Factor: Medium

Score: 5.7

CVSS v2

Risk Factor: Medium

Base Score: 5.8

Temporal Score: 4.5

Vector: AV:N/AC:M/Au:N/C:N/I:P/A:P

Temporal Vector: E:POC/RL:OF/RC:C

CVSS Score Source: CVE-2020-12825

CVSS v3

Risk Factor: High

Base Score: 7.1

Temporal Score: 6.4

Vector: CVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:U/C:N/I:L/A:H

Temporal Vector: E:P/RL:O/RC:C

Vulnerability Information

CPE: cpe:/o:canonical:ubuntu_linux:16.04:-:lts, p-cpe:/a:canonical:ubuntu_linux:libcroco-tools, p-cpe:/a:canonical:ubuntu_linux:libcroco3, p-cpe:/a:canonical:ubuntu_linux:libcroco3-dev

Required KB Items: Host/cpu, Host/Ubuntu, Host/Ubuntu/release, Host/Debian/dpkg-l

Exploit Available: true

Exploit Ease: Exploits are available

Patch Publication Date: 4/26/2022

Vulnerability Publication Date: 4/19/2017

Reference Information

CVE: CVE-2017-7960, CVE-2017-8834, CVE-2017-8871, CVE-2020-12825

USN: 5389-1