CVE-2020-12825

high
New! CVE Severity Now Using CVSS v3

The calculated severity for CVEs has been updated to use CVSS v3 by default. CVEs that do not have a CVSS v3 score will fall back CVSS v2 for calculating severity. Severity display preferences can be toggled in the settings dropdown.

Description

libcroco through 0.6.13 has excessive recursion in cr_parser_parse_any_core in cr-parser.c, leading to stack consumption.

References

http://www.openwall.com/lists/oss-security/2020/08/13/3

http://www.openwall.com/lists/oss-security/2020/09/08/3

https://gitlab.gnome.org/GNOME/libcroco/-/issues/8

Details

Source: MITRE

Published: 2020-05-12

Updated: 2020-09-08

Type: CWE-674

Risk Information

CVSS v2

Base Score: 5.8

Vector: AV:N/AC:M/Au:N/C:N/I:P/A:P

Impact Score: 4.9

Exploitability Score: 8.6

Severity: MEDIUM

CVSS v3

Base Score: 7.1

Vector: CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:N/I:L/A:H

Impact Score: 4.2

Exploitability Score: 2.8

Severity: HIGH

Vulnerable Software

Configuration 1

OR

cpe:2.3:a:gnome:libcroco:*:*:*:*:*:*:*:* versions up to 0.6.13 (inclusive)

Tenable Plugins

View all (21 total)

IDNameProductFamilySeverity
151409EulerOS Virtualization 3.0.2.2 : libcroco (EulerOS-SA-2021-2143)NessusHuawei Local Security Checks
high
147332NewStart CGSL MAIN 6.02 : libcroco Vulnerability (NS-SA-2021-0056)NessusNewStart CGSL Local Security Checks
high
147325NewStart CGSL CORE 5.04 / MAIN 5.04 : libcroco Vulnerability (NS-SA-2021-0021)NessusNewStart CGSL Local Security Checks
high
146235EulerOS 2.0 SP9 : libcroco (EulerOS-SA-2021-1248)NessusHuawei Local Security Checks
high
146228EulerOS 2.0 SP9 : libcroco (EulerOS-SA-2021-1267)NessusHuawei Local Security Checks
high
145840CentOS 8 : libcroco (CESA-2020:3654)NessusCentOS Local Security Checks
high
142609CentOS 7 : libcroco (CESA-2020:4072)NessusCentOS Local Security Checks
high
142562EulerOS Virtualization 3.0.6.6 : libcroco (EulerOS-SA-2020-2447)NessusHuawei Local Security Checks
high
142337EulerOS 2.0 SP2 : libcroco (EulerOS-SA-2020-2355)NessusHuawei Local Security Checks
high
141972Amazon Linux 2 : libcroco (ALAS-2020-1521)NessusAmazon Linux Local Security Checks
high
141761Scientific Linux Security Update : libcroco on SL7.x x86_64 (20201001)NessusScientific Linux Local Security Checks
high
141310Oracle Linux 7 : libcroco (ELSA-2020-4072)NessusOracle Linux Local Security Checks
high
141052RHEL 7 : libcroco (RHSA-2020:4072)NessusRed Hat Local Security Checks
high
140872EulerOS 2.0 SP3 : libcroco (EulerOS-SA-2020-2105)NessusHuawei Local Security Checks
high
140718Photon OS 1.0: Gettext PHSA-2020-1.0-0326NessusPhotonOS Local Security Checks
high
140483Oracle Linux 8 : libcroco (ELSA-2020-3654)NessusOracle Linux Local Security Checks
high
140461RHEL 8 : libcroco (RHSA-2020:3654)NessusRed Hat Local Security Checks
high
140356EulerOS Virtualization for ARM 64 3.0.2.0 : libcroco (EulerOS-SA-2020-1986)NessusHuawei Local Security Checks
high
140143EulerOS 2.0 SP5 : libcroco (EulerOS-SA-2020-1922)NessusHuawei Local Security Checks
high
140012EulerOS Virtualization for ARM 64 3.0.6.0 : libcroco (EulerOS-SA-2020-1909)NessusHuawei Local Security Checks
high
139138EulerOS 2.0 SP8 : libcroco (EulerOS-SA-2020-1808)NessusHuawei Local Security Checks
high