Amazon Corretto Java 8.x < 8.332.08.1 Multiple Vulnerabilities

high Nessus Plugin ID 159899

Synopsis

Amazon Corretto is affected by multiple vulnerabilities.

Description

The version of Amazon Corretto installed on the remote host is prior to 8 < 8.332.08.1. It is, therefore, affected by multiple vulnerabilities as referenced in the corretto-8-2022-Apr-19 advisory.

- zlib before 1.2.12 allows memory corruption when deflating (i.e., when compressing) if the input has many distant matches. (CVE-2018-25032)

- xml/jaxp (CVE-2022-21426)

- core-libs/java.lang (CVE-2022-21434)

- security-libs/java.security (CVE-2022-21443, CVE-2022-21476)

- core-libs/javax.naming (CVE-2022-21496)

Note that Nessus has not tested for these issues but has instead relied only on the application's self-reported version number.

Solution

Update to Amazon Corretto Java 8.332.08.1 or later

See Also

http://www.nessus.org/u?cc5e0452

Plugin Details

Severity: High

ID: 159899

File Name: amazon_corretto_8_332_08_1.nasl

Version: 1.6

Type: local

Agent: windows, macosx, unix

Family: Misc.

Published: 4/19/2022

Updated: 11/1/2023

Configuration: Enable thorough checks

Supported Sensors: Nessus Agent, Nessus

Risk Information

VPR

Risk Factor: Medium

Score: 5.1

CVSS v2

Risk Factor: Medium

Base Score: 5

Temporal Score: 4.1

Vector: CVSS2#AV:N/AC:L/Au:N/C:N/I:P/A:N

CVSS Score Source: CVE-2022-21496

CVSS v3

Risk Factor: High

Base Score: 7.5

Temporal Score: 7

Vector: CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:N

Temporal Vector: CVSS:3.0/E:F/RL:O/RC:C

CVSS Score Source: CVE-2022-21476

Vulnerability Information

CPE: cpe:/a:amazon:corretto

Required KB Items: installed_sw/Java

Exploit Available: true

Exploit Ease: Exploits are available

Patch Publication Date: 4/19/2022

Vulnerability Publication Date: 3/25/2022

Reference Information

CVE: CVE-2018-25032, CVE-2022-21426, CVE-2022-21434, CVE-2022-21443, CVE-2022-21476, CVE-2022-21496