Amazon Corretto Java 11.x < 11.0.7.10.1 Multiple Vulnerabilities

high Nessus Plugin ID 159438

Synopsis

Amazon Corretto is affected by multiple vulnerabilities.

Description

The version of Amazon Corretto installed on the remote host is prior to 11 < 11.0.7.10.1. It is, therefore, affected by multiple vulnerabilities as referenced in the corretto-11-2020-Apr-14 advisory.

- core-libs/javax.script (CVE-2020-2754, CVE-2020-2755)

- core-libs/java.io:serialization (CVE-2020-2756, CVE-2020-2757)

- security-libs/javax.net.ssl (CVE-2020-2767, CVE-2020-2778, CVE-2020-2816)

- security-libs/javax.xml.crypto (CVE-2020-2773)

- security-libs/java.security (CVE-2020-2781)

- core-libs/java.net (CVE-2020-2800)

- core-libs/java.nio (CVE-2020-2803)

- core-libs/java.io (CVE-2020-2805)

- core-libs/java.util (CVE-2020-2830)

Note that Nessus has not tested for these issues but has instead relied only on the application's self-reported version number.

Solution

Update to Amazon Corretto Java 11.0.7.10.1 or later

See Also

http://www.nessus.org/u?bc075435

Plugin Details

Severity: High

ID: 159438

File Name: amazon_corretto_11_0_7_10_1.nasl

Version: 1.5

Type: local

Agent: windows, macosx, unix

Family: Misc.

Published: 4/1/2022

Updated: 5/6/2022

Configuration: Enable thorough checks

Supported Sensors: Nessus Agent

Risk Information

VPR

Risk Factor: High

Score: 7.3

CVSS v2

Risk Factor: Medium

Base Score: 5.8

Temporal Score: 4.3

Vector: AV:N/AC:M/Au:N/C:P/I:P/A:N

Temporal Vector: E:U/RL:OF/RC:C

CVSS Score Source: CVE-2020-2800

CVSS v3

Risk Factor: High

Base Score: 8.3

Temporal Score: 7.2

Vector: CVSS:3.0/AV:N/AC:H/PR:N/UI:R/S:C/C:H/I:H/A:H

Temporal Vector: E:U/RL:O/RC:C

CVSS Score Source: CVE-2020-2805

Vulnerability Information

CPE: cpe:/a:amazon:corretto

Required KB Items: installed_sw/Java

Exploit Ease: No known exploits are available

Patch Publication Date: 4/14/2020

Vulnerability Publication Date: 4/14/2020

Reference Information

CVE: CVE-2020-2754, CVE-2020-2755, CVE-2020-2756, CVE-2020-2757, CVE-2020-2767, CVE-2020-2773, CVE-2020-2778, CVE-2020-2781, CVE-2020-2800, CVE-2020-2803, CVE-2020-2805, CVE-2020-2816, CVE-2020-2830