AlmaLinux 8 : mingw packages (ALSA-2021:1968)

high Nessus Plugin ID 157470

Synopsis

The remote AlmaLinux host is missing one or more security updates.

Description

The remote AlmaLinux 8 host has packages installed that are affected by multiple vulnerabilities as referenced in the ALSA-2021:1968 advisory.

- In SQLite through 3.29.0, whereLoopAddBtreeIndex in sqlite3.c can crash a browser or other application because of missing validation of a sqlite_stat1 sz field, aka a severe division by zero in the query planner. (CVE-2019-16168)

- SQLite through 3.32.0 has an integer overflow in sqlite3_str_vappendf in printf.c. (CVE-2020-13434)

- ext/fts3/fts3.c in SQLite before 3.32.0 has a use-after-free in fts3EvalNextRow, related to the snippet feature. (CVE-2020-13630)

- SQLite before 3.32.0 allows a virtual table to be renamed to the name of one of its shadow tables, related to alter.c and build.c. (CVE-2020-13631)

- ext/fts3/fts3_snippet.c in SQLite before 3.32.0 has a NULL pointer dereference via a crafted matchinfo() query. (CVE-2020-13632)

Note that Nessus has not tested for this issue but has instead relied only on the application's self-reported version number.

Solution

Update the affected packages.

See Also

https://errata.almalinux.org/8/ALSA-2021-1968.html

Plugin Details

Severity: High

ID: 157470

File Name: alma_linux_ALSA-2021-1968.nasl

Version: 1.3

Type: local

Published: 2/9/2022

Updated: 2/14/2022

Risk Information

VPR

Risk Factor: Medium

Score: 6.7

CVSS v2

Risk Factor: Medium

Base Score: 4.4

Temporal Score: 3.3

Vector: AV:L/AC:M/Au:N/C:P/I:P/A:P

Temporal Vector: E:U/RL:OF/RC:C

CVSS Score Source: CVE-2020-13630

CVSS v3

Risk Factor: High

Base Score: 7

Temporal Score: 6.1

Vector: CVSS:3.0/AV:L/AC:H/PR:L/UI:N/S:U/C:H/I:H/A:H

Temporal Vector: E:U/RL:O/RC:C

Vulnerability Information

CPE: p-cpe:/a:alma:linux:mingw-binutils-generic, p-cpe:/a:alma:linux:mingw-filesystem-base, p-cpe:/a:alma:linux:mingw32-binutils, p-cpe:/a:alma:linux:mingw32-bzip2, p-cpe:/a:alma:linux:mingw32-bzip2-static, p-cpe:/a:alma:linux:mingw32-filesystem, p-cpe:/a:alma:linux:mingw32-sqlite, p-cpe:/a:alma:linux:mingw32-sqlite-static, p-cpe:/a:alma:linux:mingw64-binutils, p-cpe:/a:alma:linux:mingw64-bzip2, p-cpe:/a:alma:linux:mingw64-bzip2-static, p-cpe:/a:alma:linux:mingw64-filesystem, p-cpe:/a:alma:linux:mingw64-sqlite, p-cpe:/a:alma:linux:mingw64-sqlite-static, cpe:/o:alma:linux:8

Required KB Items: Host/local_checks_enabled, Host/AlmaLinux/release, Host/AlmaLinux/rpm-list, Host/cpu

Exploit Ease: No known exploits are available

Patch Publication Date: 5/18/2021

Vulnerability Publication Date: 9/9/2019

Reference Information

CVE: CVE-2019-16168, CVE-2020-13434, CVE-2020-13630, CVE-2020-13631, CVE-2020-13632

ALSA: 2021:1968

IAVA: 2020-A-0021-S, 2020-A-0358-S