RHEL 7 : httpd (RHSA-2022:0143)

critical Nessus Plugin ID 156774

Synopsis

The remote Red Hat host is missing one or more security updates.

Description

The remote Redhat Enterprise Linux 7 host has packages installed that are affected by multiple vulnerabilities as referenced in the RHSA-2022:0143 advisory.

- httpd: mod_session: Heap overflow via a crafted SessionHeader value (CVE-2021-26691)

- httpd: NULL pointer dereference via malformed requests (CVE-2021-34798)

- httpd: Out-of-bounds write in ap_escape_quotes() via malicious input (CVE-2021-39275)

- httpd: mod_lua: Possible buffer overflow when parsing multipart content (CVE-2021-44790)

Note that Nessus has not tested for this issue but has instead relied only on the application's self-reported version number.

Solution

Update the affected packages.

See Also

https://cwe.mitre.org/data/definitions/119.html

https://cwe.mitre.org/data/definitions/400.html

https://cwe.mitre.org/data/definitions/476.html

https://cwe.mitre.org/data/definitions/787.html

https://access.redhat.com/security/cve/CVE-2021-26691

https://access.redhat.com/security/cve/CVE-2021-34798

https://access.redhat.com/security/cve/CVE-2021-39275

https://access.redhat.com/security/cve/CVE-2021-44790

https://access.redhat.com/errata/RHSA-2022:0143

https://bugzilla.redhat.com/1966732

https://bugzilla.redhat.com/2005119

https://bugzilla.redhat.com/2005128

https://bugzilla.redhat.com/2034674

Plugin Details

Severity: Critical

ID: 156774

File Name: redhat-RHSA-2022-0143.nasl

Version: 1.4

Type: local

Agent: unix

Published: 1/17/2022

Updated: 4/27/2022

Supported Sensors: Frictionless Assessment Agent, Frictionless Assessment AWS, Frictionless Assessment Azure, Nessus Agent

Risk Information

CVSS Score Source: CVE-2021-44790

VPR

Risk Factor: Critical

Score: 9

CVSS v2

Risk Factor: High

Base Score: 7.5

Temporal Score: 5.5

Vector: AV:N/AC:L/Au:N/C:P/I:P/A:P

Temporal Vector: E:U/RL:OF/RC:C

CVSS v3

Risk Factor: Critical

Base Score: 9.8

Temporal Score: 8.5

Vector: CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H

Temporal Vector: E:U/RL:O/RC:C

Vulnerability Information

CPE: cpe:/o:redhat:enterprise_linux:7, p-cpe:/a:redhat:enterprise_linux:httpd, p-cpe:/a:redhat:enterprise_linux:httpd-devel, p-cpe:/a:redhat:enterprise_linux:httpd-manual, p-cpe:/a:redhat:enterprise_linux:httpd-tools, p-cpe:/a:redhat:enterprise_linux:mod_ldap, p-cpe:/a:redhat:enterprise_linux:mod_proxy_html, p-cpe:/a:redhat:enterprise_linux:mod_session, p-cpe:/a:redhat:enterprise_linux:mod_ssl

Required KB Items: Host/local_checks_enabled, Host/RedHat/release, Host/RedHat/rpm-list, Host/cpu

Exploit Ease: No known exploits are available

Patch Publication Date: 1/17/2022

Vulnerability Publication Date: 6/6/2021

Reference Information

CVE: CVE-2021-26691, CVE-2021-34798, CVE-2021-39275, CVE-2021-44790

RHSA: 2022:0143

IAVA: 2021-A-0259-S, 2021-A-0482, 2021-A-0440-S, 2021-A-0604-S

CWE: 119, 400, 476, 787