FreeBSD : Gitlab -- Multiple Vulnerabilities (43f84437-73ab-11ec-a587-001b217b3468)

high Nessus Plugin ID 156715

Language:

Synopsis

The remote FreeBSD host is missing one or more security-related updates.

Description

The version of FreeBSD installed on the remote host is prior to tested version. It is, therefore, affected by multiple vulnerabilities as referenced in the 43f84437-73ab-11ec-a587-001b217b3468 advisory.

- Gitlab reports: Arbitrary file read via group import feature Stored XSS in notes Lack of state parameter on GitHub import project OAuth Vulnerability related fields are available to unauthorized users on GraphQL API Deleting packages may cause table locks IP restriction bypass via GraphQL Repository content spoofing using Git replacement references Users can import members from projects that they are not a maintainer on through API Possibility to direct user to malicious site through Slack integration Bypassing file size limits to the NPM package repository User with expired password can still access sensitive information Incorrect port validation allows access to services on ports 80 and 443 if GitLab is configured to run on another port (CVE-2021-39927, CVE-2021-39942, CVE-2021-39946, CVE-2022-0090, CVE-2022-0093, CVE-2022-0124, CVE-2022-0125, CVE-2022-0151, CVE-2022-0152, CVE-2022-0154, CVE-2022-0172)

Note that Nessus has not tested for this issue but has instead relied only on the application's self-reported version number.

Solution

Update the affected packages.

See Also

http://www.nessus.org/u?90ddb636

http://www.nessus.org/u?8f473483

Plugin Details

Severity: High

ID: 156715

File Name: freebsd_pkg_43f8443773ab11eca587001b217b3468.nasl

Version: 1.6

Type: local

Published: 1/13/2022

Updated: 5/6/2022

Risk Information

VPR

Risk Factor: Medium

Score: 5.9

CVSS v2

Risk Factor: Medium

Base Score: 6.4

Temporal Score: 4.7

Vector: AV:N/AC:L/Au:N/C:P/I:P/A:N

Temporal Vector: E:U/RL:OF/RC:C

CVSS Score Source: CVE-2022-0172

CVSS v3

Risk Factor: High

Base Score: 8

Temporal Score: 7

Vector: CVSS:3.0/AV:N/AC:L/PR:L/UI:R/S:U/C:H/I:H/A:H

Temporal Vector: E:U/RL:O/RC:C

CVSS Score Source: CVE-2022-0154

Vulnerability Information

CPE: p-cpe:/a:freebsd:freebsd:gitlab-ce, cpe:/o:freebsd:freebsd

Required KB Items: Host/local_checks_enabled, Host/FreeBSD/release, Host/FreeBSD/pkg_info

Exploit Ease: No known exploits are available

Patch Publication Date: 1/12/2022

Vulnerability Publication Date: 1/11/2022

Reference Information

CVE: CVE-2021-39927, CVE-2021-39942, CVE-2021-39946, CVE-2022-0090, CVE-2022-0093, CVE-2022-0124, CVE-2022-0125, CVE-2022-0151, CVE-2022-0152, CVE-2022-0154, CVE-2022-0172

IAVA: 2022-A-0021-S