Adobe Bridge 11.x < 11.1.3 / 12.x < 12.0.1 Multiple Vulnerabilities (APSB22-03)

high Nessus Plugin ID 156662

Synopsis

Adobe Bridge installed on remote macOS or Mac OS X host is affected by a multiple vulnerabilities

Description

The version of Adobe Bridge installed on the remote macOS or Mac OS X host is prior to 12.0.1 or 11.1.3. It is, therefore, affected by multiple vulnerabilities as referenced in the apsb22-03 advisory.

- Adobe Bridge version 11.1.2 (and earlier) and version 12.0 (and earlier) are affected by an out-of-bounds write vulnerability that could result in arbitrary code execution in the context of the current user.
Exploitation of this issue requires user interaction in that a victim must open a malicious file.
(CVE-2021-44743)

- Adobe Bridge version 11.1.2 (and earlier) and version 12.0 (and earlier) are affected by an out-of-bounds read vulnerability that could lead to disclosure of sensitive memory. An attacker could leverage this vulnerability to bypass mitigations such as ASLR. Exploitation of this issue requires user interaction in that a victim must open a malicious RGB file. (CVE-2021-44185)

- Adobe Bridge version 11.1.2 (and earlier) and version 12.0 (and earlier) are affected by an out-of-bounds read vulnerability that could lead to disclosure of sensitive memory. An attacker could leverage this vulnerability to bypass mitigations such as ASLR. Exploitation of this issue requires user interaction in that a victim must open a malicious SGI file. (CVE-2021-44186, CVE-2021-44187)

- Adobe Bridge version 11.1.2 (and earlier) and version 12.0 (and earlier) are affected by an use-after-free vulnerability in the processing of Format event actions that could lead to disclosure of sensitive memory.
An attacker could leverage this vulnerability to bypass mitigations such as ASLR. Exploitation of this issue requires user interaction in that a victim must open a malicious file. (CVE-2021-45051)

- Adobe Bridge version 11.1.2 (and earlier) and version 12.0 (and earlier) are affected by an out-of-bounds read vulnerability that could lead to disclosure of sensitive memory. An attacker could leverage this vulnerability to bypass mitigations such as ASLR. Exploitation of this issue requires user interaction in that a victim must open a malicious TIF file. (CVE-2021-45052)

Note that Nessus has not tested for this issue but has instead relied only on the application's self-reported version number.

Solution

Upgrade to Adobe Bridge version 12.0.1 or 11.1.3 or later.

See Also

https://cwe.mitre.org/data/definitions/125.html

https://cwe.mitre.org/data/definitions/416.html

https://cwe.mitre.org/data/definitions/787.html

https://helpx.adobe.com/security/products/bridge/apsb22-03.html

Plugin Details

Severity: High

ID: 156662

File Name: macos_adobe_bridge_apsb22-03.nasl

Version: 1.6

Type: local

Agent: macosx

Published: 1/12/2022

Updated: 6/20/2022

Supported Sensors: Nessus Agent

Risk Information

VPR

Risk Factor: Medium

Score: 5.9

CVSS v2

Risk Factor: High

Base Score: 9.3

Temporal Score: 6.9

Vector: AV:N/AC:M/Au:N/C:C/I:C/A:C

Temporal Vector: E:U/RL:OF/RC:C

CVSS Score Source: CVE-2021-44743

CVSS v3

Risk Factor: High

Base Score: 7.8

Temporal Score: 6.8

Vector: CVSS:3.0/AV:L/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H

Temporal Vector: E:U/RL:O/RC:C

Vulnerability Information

CPE: cpe:/a:adobe:bridge

Required KB Items: Host/local_checks_enabled, Host/MacOSX/Version, installed_sw/Adobe Bridge

Exploit Ease: No known exploits are available

Patch Publication Date: 1/11/2022

Vulnerability Publication Date: 12/7/2021

Reference Information

CVE: CVE-2021-44185, CVE-2021-44186, CVE-2021-44187, CVE-2021-44743, CVE-2021-45051, CVE-2021-45052

IAVA: 2022-A-0015-S

CWE: 125, 416, 787