Apache JSPWiki Log4Shell Direct Check (CVE-2021-44228)

critical Nessus Plugin ID 156558

Synopsis

The remote web server contains a Java application that is affected by a remote code execution vulnerability.

Description

The version of Apache JSPWiki running on the remote web server is affected by a remote code execution vulnerability in the bundled Apache Log4j logging library. Apache Log4j is vulnerable due to insufficient protections on message lookup substitutions when dealing with user controlled input. A remote, unauthenticated attacker can exploit this, via a web request, to execute arbitrary code with the permission level of the running Java process.

This plugin requires that both the scanner and target machine have internet access.

Solution

Upgrade to Apache JSPWiki version 2.11.1 or later.

See Also

http://www.nessus.org/u?ae74aac3

http://www.nessus.org/u?967acbea

Plugin Details

Severity: Critical

ID: 156558

File Name: apache_jspwiki_log4shell.nbin

Version: 1.10

Type: remote

Family: CGI abuses

Published: 1/7/2022

Updated: 5/24/2022

Risk Information

CVSS Score Source: CVE-2021-44228

VPR

Risk Factor: Critical

Score: 10

CVSS v2

Risk Factor: High

Base Score: 9.3

Temporal Score: 8.1

Vector: AV:N/AC:M/Au:N/C:C/I:C/A:C

Temporal Vector: E:H/RL:OF/RC:C

CVSS v3

Risk Factor: Critical

Base Score: 10

Temporal Score: 9.5

Vector: CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:C/C:H/I:H/A:H

Temporal Vector: E:H/RL:O/RC:C

Vulnerability Information

CPE: cpe:/a:apache:jspwiki

Excluded KB Items: Settings/disable_cgi_scanning

Exploit Available: true

Exploit Ease: Exploits are available

Patch Publication Date: 12/18/2021

Vulnerability Publication Date: 12/10/2021

CISA Known Exploited Dates: 12/24/2021

Reference Information

CVE: CVE-2021-44228

IAVA: 0001-A-0650, 2021-A-0573