Apache HTTP Server 2.4.49 & 2.4.50 Path Traversal (CVE-2021-42013)

critical Nessus Plugin ID 155600

Synopsis

The remote web server is affected by a path traversal vulnerability.

Description

The instance of Apache HTTP Server running on the remote host is affected by a path traversal vulnerability. A remote, unauthenticated attacker can exploit this issue, via a specially crafted HTTP request, to access arbitrary files on the remote host.

Solution

Upgrade to Apache HTTP Server version 2.4.51 or later.

See Also

https://httpd.apache.org/security/vulnerabilities_24.html

Plugin Details

Severity: Critical

ID: 155600

File Name: apache_2_4_50_path_traversal.nbin

Version: 1.10

Type: remote

Family: CGI abuses

Published: 11/18/2021

Updated: 4/25/2022

Risk Information

CVSS Score Source: CVE-2021-42013

VPR

Risk Factor: Critical

Score: 9.4

CVSS v2

Risk Factor: High

Base Score: 7.5

Temporal Score: 6.5

Vector: AV:N/AC:L/Au:N/C:P/I:P/A:P

Temporal Vector: E:H/RL:OF/RC:C

CVSS v3

Risk Factor: Critical

Base Score: 9.8

Temporal Score: 9.4

Vector: CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H

Temporal Vector: E:H/RL:O/RC:C

Vulnerability Information

CPE: cpe:/a:apache:httpd, cpe:/a:apache:http_server

Required KB Items: installed_sw/Apache

Exploit Available: true

Exploit Ease: Exploits are available

Patch Publication Date: 10/7/2021

Vulnerability Publication Date: 10/7/2021

CISA Known Exploited Dates: 11/17/2021

Exploitable With

Metasploit (Apache 2.4.49/2.4.50 Traversal RCE)

Elliot (Apache 2.4.50 RCE)

Reference Information

CVE: CVE-2021-42013