SUSE-SA:2004:038: libtiff

Critical Nessus Plugin ID 15552


The remote host is missing a vendor-supplied security patch


The remote host is missing the patch for the advisory SUSE-SA:2004:038 (libtiff).

libtiff is used by image viewers and web browser to view 'TIFF' images.
These usually open and display those images without querying the user, making a normal system by default vulnerable to exploits of image library bugs.

Chris Evans found several security related problems during an audit of the image handling library libtiff, some related to buffer overflows, some related to integer overflows and similar. This issue is being tracked by the CVE ID CVE-2004-0803.

Matthias Claasen found a division by zero in libtiff. This is tracked by the CVE ID CVE-2004-0804.

Further auditing by Dmitry Levin exposed several additional integer overflows. These are tracked by the CVE ID CVE-2004-0886.

Additionally, iDEFENSE Security located a buffer overflow in the OJPEG (old JPEG) handling in the SUSE libtiff package. This was fixed by disabling the old JPEG support and is tracked by the CVE ID CVE-2004-0929.

SUSE wishes to thank all the reporters, auditors, and programmers for helping to fix these problems.


Plugin Details

Severity: Critical

ID: 15552

File Name: suse_SA_2004_038.nasl

Version: $Revision: 1.9 $

Agent: unix

Published: 2004/10/22

Modified: 2010/10/06

Dependencies: 12634

Risk Information

Risk Factor: Critical


Base Score: 10

Temporal Score: 7.4

Vector: CVSS2#AV:N/AC:L/Au:N/C:C/I:C/A:C

Temporal Vector: CVSS2#E:U/RL:OF/RC:C

Vulnerability Information

Required KB Items: Host/SuSE/rpm-list

Exploit Available: false

Exploit Ease: No known exploits are available

Reference Information

CVE: CVE-2004-0803, CVE-2004-0804, CVE-2004-0886, CVE-2004-0929

BID: 11506