openSUSE 15 Security Update : qemu (openSUSE-SU-2021:3604-1)

high Nessus Plugin ID 154890

Language:

Synopsis

The remote SUSE host is missing one or more security updates.

Description

The remote SUSE Linux SUSE15 host has a package installed that is affected by multiple vulnerabilities as referenced in the openSUSE-SU-2021:3604-1 advisory.

- An out-of-bounds write flaw was found in the UAS (USB Attached SCSI) device emulation of QEMU in versions prior to 6.2.0-rc0. The device uses the guest supplied stream number unchecked, which can lead to out-of- bounds access to the UASDevice->data3 and UASDevice->status3 fields. A malicious guest user could use this flaw to crash QEMU or potentially achieve code execution with the privileges of the QEMU process on the host. (CVE-2021-3713)

- QEMU: virtio-net: heap use-after-free in virtio_net_receive_rcu (CVE-2021-3748)

Note that Nessus has not tested for this issue but has instead relied only on the application's self-reported version number.

Solution

Update the affected qemu-s390 package.

See Also

https://bugzilla.suse.com/1189702

https://bugzilla.suse.com/1189938

https://www.suse.com/security/cve/CVE-2021-3713

https://www.suse.com/security/cve/CVE-2021-3748

https://bugzilla.suse.com/1189234

https://bugzilla.suse.com/1190425

http://www.nessus.org/u?d7d04d89

Plugin Details

Severity: High

ID: 154890

File Name: openSUSE-2021-3604.nasl

Version: 1.4

Type: local

Agent: unix

Published: 11/4/2021

Updated: 1/10/2023

Supported Sensors: Frictionless Assessment AWS, Frictionless Assessment Azure, Frictionless Assessment Agent, Nessus Agent

Risk Information

VPR

Risk Factor: High

Score: 7.3

CVSS v2

Risk Factor: Medium

Base Score: 6.9

Temporal Score: 5.1

Vector: CVSS2#AV:L/AC:M/Au:N/C:C/I:C/A:C

Temporal Vector: CVSS2#E:U/RL:OF/RC:C

CVSS Score Source: CVE-2021-3748

CVSS v3

Risk Factor: High

Base Score: 7.5

Temporal Score: 6.5

Vector: CVSS:3.0/AV:L/AC:H/PR:H/UI:N/S:C/C:H/I:H/A:H

Temporal Vector: CVSS:3.0/E:U/RL:O/RC:C

Vulnerability Information

CPE: p-cpe:2.3:a:novell:opensuse:qemu-s390:*:*:*:*:*:*:*, cpe:2.3:o:novell:opensuse:15.3:*:*:*:*:*:*:*

Required KB Items: Host/local_checks_enabled, Host/cpu, Host/SuSE/release, Host/SuSE/rpm-list

Exploit Ease: No known exploits are available

Patch Publication Date: 11/3/2021

Vulnerability Publication Date: 8/25/2021

Reference Information

CVE: CVE-2021-3713, CVE-2021-3748