NewStart CGSL CORE 5.05 / MAIN 5.05 : librabbitmq Vulnerability (NS-SA-2021-0163)

critical Nessus Plugin ID 154570

Synopsis

The remote NewStart CGSL host is affected by a vulnerability.

Description

The remote NewStart CGSL host, running version CORE 5.05 / MAIN 5.05, has librabbitmq packages installed that are affected by a vulnerability:

- An issue was discovered in amqp_handle_input in amqp_connection.c in rabbitmq-c 0.9.0. There is an integer overflow that leads to heap memory corruption in the handling of CONNECTION_STATE_HEADER. A rogue server could return a malicious frame header that leads to a smaller target_size value than needed. This condition is then carried on to a memcpy function that copies too much data into a heap buffer.
(CVE-2019-18609)

Note that Nessus has not tested for this issue but has instead relied only on the application's self-reported version number.

Solution

Upgrade the vulnerable CGSL librabbitmq packages. Note that updated packages may not be available yet. Please contact ZTE for more information.

See Also

http://security.gd-linux.com/notice/NS-SA-2021-0163

http://security.gd-linux.com/info/CVE-2019-18609

Plugin Details

Severity: Critical

ID: 154570

File Name: newstart_cgsl_NS-SA-2021-0163_librabbitmq.nasl

Version: 1.2

Type: local

Published: 10/27/2021

Updated: 10/27/2021

Risk Information

VPR

Risk Factor: Medium

Score: 5.9

CVSS v2

Risk Factor: High

Base Score: 7.5

Temporal Score: 5.5

Vector: AV:N/AC:L/Au:N/C:P/I:P/A:P

Temporal Vector: E:U/RL:OF/RC:C

CVSS Score Source: CVE-2019-18609

CVSS v3

Risk Factor: Critical

Base Score: 9.8

Temporal Score: 8.5

Vector: CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H

Temporal Vector: E:U/RL:O/RC:C

Vulnerability Information

CPE: p-cpe:/a:zte:cgsl_core:librabbitmq, p-cpe:/a:zte:cgsl_core:librabbitmq-devel, p-cpe:/a:zte:cgsl_core:librabbitmq-examples, p-cpe:/a:zte:cgsl_main:librabbitmq, p-cpe:/a:zte:cgsl_main:librabbitmq-devel, p-cpe:/a:zte:cgsl_main:librabbitmq-examples, cpe:/o:zte:cgsl_core:5, cpe:/o:zte:cgsl_main:5

Required KB Items: Host/local_checks_enabled, Host/ZTE-CGSL/release, Host/ZTE-CGSL/rpm-list, Host/cpu

Exploit Ease: No known exploits are available

Patch Publication Date: 9/24/2021

Vulnerability Publication Date: 12/1/2019

Reference Information

CVE: CVE-2019-18609