NewStart CGSL CORE 5.05 / MAIN 5.05 : qt Vulnerability (NS-SA-2021-0149)

medium Nessus Plugin ID 154532

Synopsis

The remote NewStart CGSL host is affected by a vulnerability.

Description

The remote NewStart CGSL host, running version CORE 5.05 / MAIN 5.05, has qt packages installed that are affected by a vulnerability:

- An issue was discovered in Qt through 5.12.9, and 5.13.x through 5.15.x before 5.15.1. read_xbm_body in gui/image/qxbmhandler.cpp has a buffer over-read. (CVE-2020-17507)

Note that Nessus has not tested for this issue but has instead relied only on the application's self-reported version number.

Solution

Upgrade the vulnerable CGSL qt packages. Note that updated packages may not be available yet. Please contact ZTE for more information.

See Also

http://security.gd-linux.com/notice/NS-SA-2021-0149

http://security.gd-linux.com/info/CVE-2020-17507

Plugin Details

Severity: Medium

ID: 154532

File Name: newstart_cgsl_NS-SA-2021-0149_qt.nasl

Version: 1.2

Type: local

Published: 10/27/2021

Updated: 10/27/2021

Risk Information

VPR

Risk Factor: Low

Score: 1.4

CVSS v2

Risk Factor: Medium

Base Score: 5

Temporal Score: 3.7

Vector: AV:N/AC:L/Au:N/C:N/I:N/A:P

Temporal Vector: E:U/RL:OF/RC:C

CVSS Score Source: CVE-2020-17507

CVSS v3

Risk Factor: Medium

Base Score: 5.3

Temporal Score: 4.6

Vector: CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:L

Temporal Vector: E:U/RL:O/RC:C

Vulnerability Information

CPE: p-cpe:/a:zte:cgsl_core:qt, p-cpe:/a:zte:cgsl_core:qt-assistant, p-cpe:/a:zte:cgsl_core:qt-config, p-cpe:/a:zte:cgsl_core:qt-demos, p-cpe:/a:zte:cgsl_core:qt-devel, p-cpe:/a:zte:cgsl_core:qt-devel-private, p-cpe:/a:zte:cgsl_core:qt-doc, p-cpe:/a:zte:cgsl_core:qt-examples, p-cpe:/a:zte:cgsl_core:qt-mysql, p-cpe:/a:zte:cgsl_core:qt-odbc, p-cpe:/a:zte:cgsl_core:qt-postgresql, p-cpe:/a:zte:cgsl_core:qt-qdbusviewer, p-cpe:/a:zte:cgsl_core:qt-qvfb, p-cpe:/a:zte:cgsl_core:qt-x11, p-cpe:/a:zte:cgsl_main:qt, p-cpe:/a:zte:cgsl_main:qt-assistant, p-cpe:/a:zte:cgsl_main:qt-config, p-cpe:/a:zte:cgsl_main:qt-demos, p-cpe:/a:zte:cgsl_main:qt-devel, p-cpe:/a:zte:cgsl_main:qt-devel-private, p-cpe:/a:zte:cgsl_main:qt-doc, p-cpe:/a:zte:cgsl_main:qt-examples, p-cpe:/a:zte:cgsl_main:qt-mysql, p-cpe:/a:zte:cgsl_main:qt-odbc, p-cpe:/a:zte:cgsl_main:qt-postgresql, p-cpe:/a:zte:cgsl_main:qt-qdbusviewer, p-cpe:/a:zte:cgsl_main:qt-qvfb, p-cpe:/a:zte:cgsl_main:qt-x11, cpe:/o:zte:cgsl_core:5, cpe:/o:zte:cgsl_main:5

Required KB Items: Host/local_checks_enabled, Host/ZTE-CGSL/release, Host/ZTE-CGSL/rpm-list, Host/cpu

Exploit Ease: No known exploits are available

Patch Publication Date: 9/24/2021

Vulnerability Publication Date: 8/12/2020

Reference Information

CVE: CVE-2020-17507