Ubuntu 21.04 : strongSwan vulnerabilities (USN-5111-1)

info Nessus Plugin ID 154227
New! Plugin Severity Now Using CVSS v3

The calculated severity for Plugins has been updated to use CVSS v3 by default. Plugins that do not have a CVSS v3 score will fall back to CVSS v2 for calculating severity. Severity display preferences can be toggled in the settings dropdown.

Synopsis

The remote Ubuntu host is missing a security update.

Description

The remote Ubuntu 21.04 host has packages installed that are affected by a vulnerability as referenced in the USN-5111-1 advisory. Note that Nessus has not tested for this issue but has instead relied only on the application's self-reported version number.

Solution

Update the affected packages.

See Also

https://ubuntu.com/security/notices/USN-5111-1

Plugin Details

Severity: Info

ID: 154227

File Name: ubuntu_USN-5111-1.nasl

Version: 1.2

Type: local

Agent: unix

Published: 10/19/2021

Updated: 10/19/2021

Dependencies: ssh_get_info.nasl

Vulnerability Information

CPE: p-cpe:2.3:a:canonical:ubuntu_linux:libstrongswan:*:*:*:*:*:*:*, p-cpe:2.3:a:canonical:ubuntu_linux:strongswan:*:*:*:*:*:*:*, cpe:2.3:o:canonical:ubuntu_linux:21.04:*:*:*:*:*:*:*, p-cpe:2.3:a:canonical:ubuntu_linux:charon-cmd:*:*:*:*:*:*:*, p-cpe:2.3:a:canonical:ubuntu_linux:charon-systemd:*:*:*:*:*:*:*, p-cpe:2.3:a:canonical:ubuntu_linux:libcharon-extauth-plugins:*:*:*:*:*:*:*, p-cpe:2.3:a:canonical:ubuntu_linux:libcharon-extra-plugins:*:*:*:*:*:*:*, p-cpe:2.3:a:canonical:ubuntu_linux:libstrongswan-extra-plugins:*:*:*:*:*:*:*, p-cpe:2.3:a:canonical:ubuntu_linux:libstrongswan-standard-plugins:*:*:*:*:*:*:*, p-cpe:2.3:a:canonical:ubuntu_linux:strongswan-charon:*:*:*:*:*:*:*, p-cpe:2.3:a:canonical:ubuntu_linux:strongswan-libcharon:*:*:*:*:*:*:*, p-cpe:2.3:a:canonical:ubuntu_linux:strongswan-nm:*:*:*:*:*:*:*, p-cpe:2.3:a:canonical:ubuntu_linux:strongswan-pki:*:*:*:*:*:*:*, p-cpe:2.3:a:canonical:ubuntu_linux:strongswan-scepclient:*:*:*:*:*:*:*, p-cpe:2.3:a:canonical:ubuntu_linux:strongswan-starter:*:*:*:*:*:*:*, p-cpe:2.3:a:canonical:ubuntu_linux:strongswan-swanctl:*:*:*:*:*:*:*

Required KB Items: Host/cpu, Host/Debian/dpkg-l, Host/Ubuntu, Host/Ubuntu/release

Exploit Ease: No known exploits are available

Patch Publication Date: 10/19/2021

Vulnerability Publication Date: 10/19/2021

Reference Information

USN: 5111-1