SUSE SLES15 Security Update : rabbitmq-server (SUSE-SU-2021:3325-1)

medium Nessus Plugin ID 153969
New! Plugin Severity Now Using CVSS v3

The calculated severity for Plugins has been updated to use CVSS v3 by default. Plugins that do not have a CVSS v3 score will fall back to CVSS v2 for calculating severity. Severity display preferences can be toggled in the settings dropdown.

Synopsis

The remote SUSE host is missing one or more security updates.

Description

The remote SUSE Linux SLES15 host has packages installed that are affected by multiple vulnerabilities as referenced in the SUSE-SU-2021:3325-1 advisory.

- RabbitMQ all versions prior to 3.8.16 are prone to a denial of service vulnerability due to improper input validation in AMQP 1.0 client connection endpoint. A malicious user can exploit the vulnerability by sending malicious AMQP messages to the target RabbitMQ instance having the AMQP 1.0 plugin enabled.
(CVE-2021-22116)

- RabbitMQ is a multi-protocol messaging broker. In rabbitmq-server prior to version 3.8.17, a new user being added via management UI could lead to the user's bane being rendered in a confirmation message without proper script tag sanitization, potentially allowing for JavaScript code execution in the context of the page. In order for this to occur, the user must be signed in and have elevated permissions (other user management). The vulnerability is patched in RabbitMQ 3.8.17. As a workaround, disable rabbitmq_management plugin and use CLI tools for management operations and Prometheus and Grafana for metrics and monitoring. (CVE-2021-32718)

- RabbitMQ is a multi-protocol messaging broker. In rabbitmq-server prior to version 3.8.18, when a federation link was displayed in the RabbitMQ management UI via the rabbitmq_federation_management plugin, its consumer tag was rendered without proper script tag sanitization. This potentially allows for JavaScript code execution in the context of the page. The user must be signed in and have elevated permissions (manage federation upstreams and policies) for this to occur. The vulnerability is patched in RabbitMQ 3.8.18. As a workaround, disable the rabbitmq_federation_management plugin and use [CLI tools] (https://www.rabbitmq.com/cli.html) instead. (CVE-2021-32719)

Note that Nessus has not tested for these issues but has instead relied only on the application's self-reported version number.

Solution

Update the affected erlang-rabbitmq-client, rabbitmq-server and / or rabbitmq-server-plugins packages.

See Also

https://bugzilla.suse.com/1185075

https://bugzilla.suse.com/1186203

https://bugzilla.suse.com/1187818

https://bugzilla.suse.com/1187819

http://www.nessus.org/u?9567dfa0

https://www.suse.com/security/cve/CVE-2021-22116

https://www.suse.com/security/cve/CVE-2021-32718

https://www.suse.com/security/cve/CVE-2021-32719

Plugin Details

Severity: Medium

ID: 153969

File Name: suse_SU-2021-3325-1.nasl

Version: 1.3

Type: local

Agent: unix

Published: 10/10/2021

Updated: 10/12/2021

Dependencies: ssh_get_info.nasl

Risk Information

CVSS Score Source: CVE-2021-32719

VPR

Risk Factor: Low

Score: 3.6

CVSS v2

Risk Factor: Low

Base Score: 3.5

Temporal Score: 2.6

Vector: AV:N/AC:M/Au:S/C:N/I:P/A:N

Temporal Vector: E:U/RL:OF/RC:C

CVSS v3

Risk Factor: Medium

Base Score: 4.8

Temporal Score: 4.2

Vector: CVSS:3.0/AV:N/AC:L/PR:H/UI:R/S:C/C:L/I:L/A:N

Temporal Vector: E:U/RL:O/RC:C

Vulnerability Information

CPE: p-cpe:/a:novell:suse_linux:erlang-rabbitmq-client, p-cpe:/a:novell:suse_linux:rabbitmq-server, p-cpe:/a:novell:suse_linux:rabbitmq-server-plugins, cpe:/o:novell:suse_linux:15

Required KB Items: Host/local_checks_enabled, Host/cpu, Host/SuSE/release, Host/SuSE/rpm-list

Exploit Ease: No known exploits are available

Patch Publication Date: 10/9/2021

Vulnerability Publication Date: 5/20/2021

Reference Information

CVE: CVE-2021-22116, CVE-2021-32718, CVE-2021-32719

SuSE: SUSE-SU-2021:3325-1

IAVB: 2021-B-0029-S, 2021-B-0043