Adobe InDesign <= 16.3 Multiple Arbitrary Code Execution Vulnerabilities (APSB21-73) (macOS)

high Nessus Plugin ID 153438

Synopsis

The remote host has an application installed that is affected by multiple arbitrary code execution vulnerabilities.

Description

The version of Adobe InDesign installed on the remote macOS host is prior or equal to 16.3. It is, therefore, affected by multiple arbitrary code execution vulnerabilities, as follows:

- Accessing a memory location after the end of the buffer allows an unauthenticated, remote attacker to execute arbitrary code. (CVE-2021-39820)

- Out-of-bounds-reads allows a local attacker to execute arbitrary code. (CVE-2021-39821, CVE-2021-39822)

Note that Nessus has not tested for these issues but has instead relied only on the application's self-reported version number.

Solution

Upgrade to Adobe InDesign version 16.4 or later.

See Also

http://www.nessus.org/u?0a1533c3

Plugin Details

Severity: High

ID: 153438

File Name: macosx_adobe_indesign_apsb21-73.nasl

Version: 1.5

Type: local

Agent: macosx

Published: 9/16/2021

Updated: 1/26/2022

Supported Sensors: Nessus Agent

Risk Information

VPR

Risk Factor: Medium

Score: 6.7

CVSS v2

Risk Factor: High

Base Score: 9.3

Temporal Score: 6.9

Vector: AV:N/AC:M/Au:N/C:C/I:C/A:C

Temporal Vector: E:U/RL:OF/RC:C

CVSS Score Source: CVE-2021-39820

CVSS v3

Risk Factor: High

Base Score: 8.8

Temporal Score: 7.7

Vector: CVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H

Temporal Vector: E:U/RL:O/RC:C

Vulnerability Information

CPE: cpe:/a:adobe:indesign

Required KB Items: Host/local_checks_enabled, Host/MacOSX/Version, installed_sw/Adobe InDesign

Exploit Ease: No known exploits are available

Patch Publication Date: 9/14/2021

Vulnerability Publication Date: 9/14/2021

Reference Information

CVE: CVE-2021-39820, CVE-2021-39821, CVE-2021-39822, CVE-2021-40727

IAVA: 2021-A-0419-S