Tenable SecurityCenter < 5.19.0 Multiple XSS Vulnerabilities (TNS-2021-14)

medium Nessus Plugin ID 152985


An application installed on the remote host is affected by multiple vulnerabilities.


According to its self-reported version, the Tenable SecurityCenter application installed on the remote host is less than 5.19.0 and is therefore affected by multiple vulnerabilities in the following components:
- Bootstrap
- SimpleSAML

Note that successful exploitation of the most serious issues can result in the execution of untrusted code.


Upgrade to 5.19.0 or later.

See Also


Plugin Details

Severity: Medium

ID: 152985

File Name: securitycenter_5_19_0_tns_2021_08_XSS.nasl

Version: 1.2

Type: local

Agent: unix

Family: Misc.

Published: 9/3/2021

Updated: 9/8/2021

Supported Sensors: Nessus Agent

Risk Information

CVSS Score Source: CVE-2020-11022


Risk Factor: Medium

Score: 4.6


Risk Factor: Medium

Base Score: 4.3

Temporal Score: 3.4

Vector: AV:N/AC:M/Au:N/C:N/I:P/A:N

Temporal Vector: E:POC/RL:OF/RC:C


Risk Factor: Medium

Base Score: 6.1

Temporal Score: 5.5

Vector: CVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N

Temporal Vector: E:P/RL:O/RC:C

Vulnerability Information

CPE: cpe:/a:tenable:securitycenter

Exploit Available: true

Exploit Ease: Exploits are available

Patch Publication Date: 9/1/2021

Vulnerability Publication Date: 7/22/2021

Reference Information

CVE: CVE-2016-10735, CVE-2018-14040, CVE-2018-14042, CVE-2018-20676, CVE-2018-20677, CVE-2019-8331, CVE-2020-11022