Atlassian Confluence < 6.13.23 / 6.14 < 7.4.11 / 7.5 < 7.11.6 / 7.12 < 7.12.5 Webwork OGNL Injection (CONFSERVER-67940)

critical Nessus Plugin ID 152864
New! Plugin Severity Now Using CVSS v3

The calculated severity for Plugins has been updated to use CVSS v3 by default. Plugins that do not have a CVSS v3 score will fall back to CVSS v2 for calculating severity. Severity display preferences can be toggled in the settings dropdown.

Synopsis

A web application running on the remote host is affected by an OGNL injection vulnerability

Description

According to its self-reported version number, the Atlassian Confluence application running on the remote host is prior to 6.13.23, 6.14.x prior to 7.4.11, 7.5.x prior to 7.11.6 or 7.12.x prior to 7.12.5. It is, therefore, affected by an OGNL injection vulnerability that would allow an authenticated user, and in some instances an unauthenticated user, to execute arbitrary code on a Confluence Server or Data Center instance.

Note that Nessus has not tested for this issue but has instead relied only on the application's self-reported version number.

Solution

Upgrade to Atlassian Confluence version 6.13.23, 7.4.11, 7.11.6, 7.12.5 or later.

See Also

http://www.nessus.org/u?7cb62fdb

https://jira.atlassian.com/browse/CONFSERVER-67940

Plugin Details

Severity: Critical

ID: 152864

File Name: confluence_confserver-67940.nasl

Version: 1.7

Type: remote

Family: CGI abuses

Published: 8/26/2021

Updated: 11/30/2021

Dependencies: confluence_detect.nasl

Risk Information

CVSS Score Source: CVE-2021-26084

VPR

Risk Factor: Critical

Score: 9.9

CVSS v2

Risk Factor: High

Base Score: 7.5

Temporal Score: 6.5

Vector: AV:N/AC:L/Au:N/C:P/I:P/A:P

Temporal Vector: E:H/RL:OF/RC:C

CVSS v3

Risk Factor: Critical

Base Score: 9.8

Temporal Score: 9.4

Vector: CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H

Temporal Vector: E:H/RL:O/RC:C

Vulnerability Information

CPE: cpe:/a:atlassian:confluence

Required KB Items: installed_sw/confluence

Exploit Available: true

Exploit Ease: Exploits are available

Patch Publication Date: 8/25/2021

Vulnerability Publication Date: 8/25/2021

Exploitable With

Metasploit (Atlassian Confluence WebWork OGNL Injection)

Reference Information

CVE: CVE-2021-26084

IAVA: 2021-A-0397