CVE-2021-26084

critical
New! CVE Severity Now Using CVSS v3

The calculated severity for CVEs has been updated to use CVSS v3 by default. CVEs that do not have a CVSS v3 score will fall back CVSS v2 for calculating severity. Severity display preferences can be toggled in the settings dropdown.

Description

In affected versions of Confluence Server and Data Center, an OGNL injection vulnerability exists that would allow an unauthenticated attacker to execute arbitrary code on a Confluence Server or Data Center instance. The affected versions are before version 6.13.23, from version 6.14.0 before 7.4.11, from version 7.5.0 before 7.11.6, and from version 7.12.0 before 7.12.5.

References

https://jira.atlassian.com/browse/CONFSERVER-67940

http://packetstormsecurity.com/files/164013/Confluence-Server-7.12.4-OGNL-Injection-Remote-Code-Execution.html

http://packetstormsecurity.com/files/164122/Atlassian-Confluence-WebWork-OGNL-Injection.html

Details

Source: MITRE

Published: 2021-08-30

Updated: 2021-09-16

Type: CWE-74

Risk Information

CVSS v2

Base Score: 7.5

Vector: AV:N/AC:L/Au:N/C:P/I:P/A:P

Impact Score: 6.4

Exploitability Score: 10

Severity: HIGH

CVSS v3

Base Score: 9.8

Vector: CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H

Impact Score: 5.9

Exploitability Score: 3.9

Severity: CRITICAL

Tenable Plugins

View all (7 total)

IDNameProductFamilySeverity
112964Atlassian Confluence 7.12.x < 7.12.5 Webwork OGNL InjectionWeb Application ScanningComponent Vulnerability
critical
112963Atlassian Confluence 7.5.x < 7.11.6 Webwork OGNL InjectionWeb Application ScanningComponent Vulnerability
critical
112962Atlassian Confluence 6.14.x < 7.4.11 Webwork OGNL InjectionWeb Application ScanningComponent Vulnerability
critical
112961Atlassian Confluence < 6.13.23 Webwork OGNL InjectionWeb Application ScanningComponent Vulnerability
critical
153087Atlassian Confluence Server Webwork OGNL Injection (CVE-2021-26084)NessusCGI abuses
critical
112944Atlassian Confluence Webwork OGNL InjectionWeb Application ScanningComponent Vulnerability
critical
152864Atlassian Confluence < 6.13.23 / 6.14 < 7.4.11 / 7.5 < 7.11.6 / 7.12 < 7.12.5 Webwork OGNL Injection (CONFSERVER-67940)NessusCGI abuses
critical