openSUSE 15 Security Update : nodejs14 (openSUSE-SU-2021:1060-1)

high Nessus Plugin ID 151814
New! Plugin Severity Now Using CVSS v3

The calculated severity for Plugins has been updated to use CVSS v3 by default. Plugins that do not have a CVSS v3 score will fall back to CVSS v2 for calculating severity. Severity display preferences can be toggled in the settings dropdown.

Synopsis

The remote SUSE host is missing one or more security updates.

Description

The remote SUSE Linux SUSE15 host has packages installed that are affected by multiple vulnerabilities as referenced in the openSUSE-SU-2021:1060-1 advisory.

- This affects the package y18n before 3.2.2, 4.0.1 and 5.0.5. PoC by po6ix: const y18n = require('y18n')();
y18n.setLocale('__proto__'); y18n.updateLocale({polluted: true}); console.log(polluted); // true (CVE-2020-7774)

- Node.js before 16.4.1, 14.17.2, 12.22.2 is vulnerable to an out-of-bounds read when uv__idna_toascii() is used to convert strings to ASCII. The pointer p is read and increased without checking whether it is beyond pe, with the latter holding a pointer to the end of the buffer. This can lead to information disclosures or crashes. This function can be triggered via uv_getaddrinfo(). (CVE-2021-22918)

- The package hosted-git-info before 3.0.8 are vulnerable to Regular Expression Denial of Service (ReDoS) via regular expression shortcutMatch in the fromUrl function in index.js. The affected regular expression exhibits polynomial worst-case time complexity. (CVE-2021-23362)

- ssri 5.2.2-8.0.0, fixed in 8.0.1, processes SRIs using a regular expression which is vulnerable to a denial of service. Malicious SRIs could take an extremely long time to process, leading to denial of service. This issue only affects consumers using the strict option. (CVE-2021-27290)

Note that Nessus has not tested for this issue but has instead relied only on the application's self-reported version number.

Solution

Update the affected nodejs14, nodejs14-devel and / or npm14 packages.

See Also

https://bugzilla.suse.com/1184450

https://bugzilla.suse.com/1187973

https://bugzilla.suse.com/1187976

https://bugzilla.suse.com/1187977

http://www.nessus.org/u?e6cd2f78

https://www.suse.com/security/cve/CVE-2020-7774

https://www.suse.com/security/cve/CVE-2021-22918

https://www.suse.com/security/cve/CVE-2021-23362

https://www.suse.com/security/cve/CVE-2021-27290

Plugin Details

Severity: High

ID: 151814

File Name: openSUSE-2021-1060.nasl

Version: 1.2

Type: local

Agent: unix

Published: 7/20/2021

Updated: 7/20/2021

Dependencies: ssh_get_info.nasl

Risk Information

CVSS Score Source: CVE-2020-7774

VPR

Risk Factor: Medium

Score: 5.9

CVSS v2

Risk Factor: High

Base Score: 7.5

Temporal Score: 5.5

Vector: AV:N/AC:L/Au:N/C:P/I:P/A:P

Temporal Vector: E:U/RL:OF/RC:C

CVSS v3

Risk Factor: High

Base Score: 7.3

Temporal Score: 6.4

Vector: CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:L/A:L

Temporal Vector: E:U/RL:O/RC:C

Vulnerability Information

CPE: p-cpe:/a:novell:opensuse:nodejs14, p-cpe:/a:novell:opensuse:nodejs14-devel, p-cpe:/a:novell:opensuse:npm14, cpe:/o:novell:opensuse:15.2

Required KB Items: Host/local_checks_enabled, Host/cpu, Host/SuSE/release, Host/SuSE/rpm-list

Exploit Ease: No known exploits are available

Patch Publication Date: 7/19/2021

Vulnerability Publication Date: 11/17/2020

Reference Information

CVE: CVE-2020-7774, CVE-2021-22918, CVE-2021-23362, CVE-2021-27290