Joomla 2.5.x < 3.9.28 Multiple Vulnerabilities (5840-joomla-3-9-28)

medium Nessus Plugin ID 151429

Language:

New! Plugin Severity Now Using CVSS v3

The calculated severity for Plugins has been updated to use CVSS v3 by default. Plugins that do not have a CVSS v3 score will fall back to CVSS v2 for calculating severity. Severity display preferences can be toggled in the settings dropdown.

Synopsis

A PHP application running on the remote web server is affected by multiple vulnerabilities.

Description

According to its self-reported version, the instance of Joomla! running on the remote web server is 2.5.x prior to 3.9.28. It is, therefore, affected by multiple vulnerabilities.

- Inadequate escaping in the Rules field of the JForm API leads to a XSS vulnerability. (CVE-2021-26035)

- Missing validation of input could lead to a broken usergroups table. (CVE-2021-26036)

- Various CMS functions did not properly termine existing user sessions when a user's password was changed or the user was blocked. (CVE-2021-26037)

- Install action in com_installer lack the required hardcoded ACL checks for superusers, leading to various potential attack vectors. A default system is not affected cause by default com_installer is limited to super users already. (CVE-2021-26038)

- Inadequate escaping in the imagelist view of com_media leads to a XSS vulnerability. (CVE-2021-26039)

Note that Nessus has not tested for this issue but has instead relied only on the application's self-reported version number.

Solution

Upgrade to Joomla! version 3.9.28 or later.

See Also

http://www.nessus.org/u?ff811b28

http://www.nessus.org/u?cc18b6c6

http://www.nessus.org/u?ea3ca23f

http://www.nessus.org/u?64f5301e

http://www.nessus.org/u?5b69b338

http://www.nessus.org/u?bf612487

Plugin Details

Severity: Medium

ID: 151429

File Name: joomla_3928.nasl

Version: 1.4

Type: remote

Family: CGI abuses

Published: 7/7/2021

Updated: 7/12/2021

Dependencies: joomla_detect.nasl

Configuration: Enable paranoid mode

Risk Information

CVSS Score Source: CVE-2021-26037

VPR

Risk Factor: Low

Score: 3.6

CVSS v2

Risk Factor: Medium

Base Score: 5

Temporal Score: 3.7

Vector: AV:N/AC:L/Au:N/C:N/I:P/A:N

Temporal Vector: E:U/RL:OF/RC:C

CVSS v3

Risk Factor: Medium

Base Score: 5.3

Temporal Score: 4.6

Vector: CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:L/A:N

Temporal Vector: E:U/RL:O/RC:C

Vulnerability Information

CPE: cpe:/a:joomla:joomla%5c%21

Required KB Items: installed_sw/Joomla!, www/PHP, Settings/ParanoidReport

Exploit Ease: No known exploits are available

Patch Publication Date: 7/6/2021

Vulnerability Publication Date: 7/6/2021

Reference Information

CVE: CVE-2021-26035, CVE-2021-26036, CVE-2021-26037, CVE-2021-26038, CVE-2021-26039