openSUSE 15 Security Update : postgresql10 (openSUSE-SU-2021:0894-1)

high Nessus Plugin ID 151075

Language:

Synopsis

The remote SUSE host is missing one or more security updates.

Description

The remote SUSE Linux SUSE15 host has packages installed that are affected by multiple vulnerabilities as referenced in the openSUSE-SU-2021:0894-1 advisory.

- A flaw was found in postgresql in versions before 13.3, before 12.7, before 11.12, before 10.17 and before 9.6.22. While modifying certain SQL array values, missing bounds checks let authenticated database users write arbitrary bytes to a wide area of server memory. The highest threat from this vulnerability is to data confidentiality and integrity as well as system availability. (CVE-2021-32027)

- postgresql: Memory disclosure in INSERT ... ON CONFLICT ... DO UPDATE (CVE-2021-32028)

Note that Nessus has not tested for this issue but has instead relied only on the application's self-reported version number.

Solution

Update the affected packages.

See Also

https://bugzilla.suse.com/1183168

https://bugzilla.suse.com/1185924

https://bugzilla.suse.com/1185925

https://www.suse.com/security/cve/CVE-2021-32027

https://www.suse.com/security/cve/CVE-2021-32028

http://www.nessus.org/u?b32a49f9

Plugin Details

Severity: High

ID: 151075

File Name: openSUSE-2021-894.nasl

Version: 1.3

Type: local

Agent: unix

Published: 6/28/2021

Updated: 8/19/2021

Supported Sensors: Nessus Agent

Risk Information

VPR

Risk Factor: Medium

Score: 5.9

CVSS v2

Risk Factor: Medium

Base Score: 6.5

Temporal Score: 4.8

Vector: CVSS2#AV:N/AC:L/Au:S/C:P/I:P/A:P

Temporal Vector: CVSS2#E:U/RL:OF/RC:C

CVSS Score Source: CVE-2021-32027

CVSS v3

Risk Factor: High

Base Score: 8.8

Temporal Score: 7.7

Vector: CVSS:3.0/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H

Temporal Vector: CVSS:3.0/E:U/RL:O/RC:C

Vulnerability Information

CPE: cpe:2.3:o:novell:opensuse:15.2:*:*:*:*:*:*:*, p-cpe:2.3:a:novell:opensuse:postgresql10:*:*:*:*:*:*:*, p-cpe:2.3:a:novell:opensuse:postgresql10-contrib:*:*:*:*:*:*:*, p-cpe:2.3:a:novell:opensuse:postgresql10-devel:*:*:*:*:*:*:*, p-cpe:2.3:a:novell:opensuse:postgresql10-plperl:*:*:*:*:*:*:*, p-cpe:2.3:a:novell:opensuse:postgresql10-plpython:*:*:*:*:*:*:*, p-cpe:2.3:a:novell:opensuse:postgresql10-pltcl:*:*:*:*:*:*:*, p-cpe:2.3:a:novell:opensuse:postgresql10-server:*:*:*:*:*:*:*, p-cpe:2.3:a:novell:opensuse:postgresql10-test:*:*:*:*:*:*:*

Required KB Items: Host/local_checks_enabled, Host/cpu, Host/SuSE/release, Host/SuSE/rpm-list

Exploit Ease: No known exploits are available

Patch Publication Date: 6/18/2021

Vulnerability Publication Date: 5/13/2021

Reference Information

CVE: CVE-2021-32028, CVE-2021-32027

IAVB: 2021-B-0036-S