Amazon Linux 2 : postgresql (ALAS-2021-1665)

high Nessus Plugin ID 150972

Synopsis

The remote Amazon Linux 2 host is missing a security update.

Description

The version of postgresql installed on the remote host is prior to 9.2.24-6. It is, therefore, affected by multiple vulnerabilities as referenced in the ALAS2-2021-1665 advisory.

- A flaw was discovered in postgresql versions 9.4.x before 9.4.24, 9.5.x before 9.5.19, 9.6.x before 9.6.15, 10.x before 10.10 and 11.x before 11.5 where arbitrary SQL statements can be executed given a suitable SECURITY DEFINER function. An attacker, with EXECUTE permission on the function, can execute arbitrary SQL as the owner of the function. (CVE-2019-10208)

- A flaw was found in PostgreSQL versions before 13.1, before 12.5, before 11.10, before 10.15, before 9.6.20 and before 9.5.24. If a client application that creates additional database connections only reuses the basic connection parameters while dropping security-relevant parameters, an opportunity for a man-in- the-middle attack, or the ability to observe clear-text transmissions, could exist. The highest threat from this vulnerability is to data confidentiality and integrity as well as system availability.
(CVE-2020-25694)

- A flaw was found in PostgreSQL versions before 13.1, before 12.5, before 11.10, before 10.15, before 9.6.20 and before 9.5.24. An attacker having permission to create non-temporary objects in at least one schema can execute arbitrary SQL functions under the identity of a superuser. The highest threat from this vulnerability is to data confidentiality and integrity as well as system availability. (CVE-2020-25695)

Note that Nessus has not tested for this issue but has instead relied only on the application's self-reported version number.

Solution

Run 'yum update postgresql' to update your system.

See Also

https://alas.aws.amazon.com/AL2/ALAS-2021-1665.html

https://access.redhat.com/security/cve/CVE-2019-10208

https://access.redhat.com/security/cve/CVE-2020-25694

https://access.redhat.com/security/cve/CVE-2020-25695

Plugin Details

Severity: High

ID: 150972

File Name: al2_ALAS-2021-1665.nasl

Version: 1.3

Type: local

Agent: unix

Published: 6/23/2021

Updated: 5/9/2022

Supported Sensors: Frictionless Assessment Agent, Frictionless Assessment AWS, Nessus Agent

Risk Information

VPR

Risk Factor: Medium

Score: 5.9

CVSS v2

Risk Factor: Medium

Base Score: 6.8

Temporal Score: 5

Vector: AV:N/AC:M/Au:N/C:P/I:P/A:P

Temporal Vector: E:U/RL:OF/RC:C

CVSS Score Source: CVE-2020-25694

CVSS v3

Risk Factor: High

Base Score: 8.8

Temporal Score: 7.7

Vector: CVSS:3.0/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H

Temporal Vector: E:U/RL:O/RC:C

CVSS Score Source: CVE-2020-25695

Vulnerability Information

CPE: p-cpe:/a:amazon:linux:postgresql, p-cpe:/a:amazon:linux:postgresql-contrib, p-cpe:/a:amazon:linux:postgresql-debuginfo, p-cpe:/a:amazon:linux:postgresql-devel, p-cpe:/a:amazon:linux:postgresql-docs, p-cpe:/a:amazon:linux:postgresql-libs, p-cpe:/a:amazon:linux:postgresql-plperl, p-cpe:/a:amazon:linux:postgresql-plpython, p-cpe:/a:amazon:linux:postgresql-pltcl, p-cpe:/a:amazon:linux:postgresql-server, p-cpe:/a:amazon:linux:postgresql-static, p-cpe:/a:amazon:linux:postgresql-test, p-cpe:/a:amazon:linux:postgresql-upgrade, cpe:/o:amazon:linux:2

Required KB Items: Host/local_checks_enabled, Host/AmazonLinux/release, Host/AmazonLinux/rpm-list

Exploit Ease: No known exploits are available

Patch Publication Date: 6/16/2021

Vulnerability Publication Date: 8/8/2019

Reference Information

CVE: CVE-2019-10208, CVE-2020-25694, CVE-2020-25695

IAVB: 2019-B-0072-S, 2020-B-0069-S

ALAS: 2021-1665