CVE-2020-25695

MEDIUM

Description

A flaw was found in PostgreSQL versions before 13.1, before 12.5, before 11.10, before 10.15, before 9.6.20 and before 9.5.24. An attacker having permission to create non-temporary objects in at least one schema can execute arbitrary SQL functions under the identity of a superuser. The highest threat from this vulnerability is to data confidentiality and integrity as well as system availability.

References

https://bugzilla.redhat.com/show_bug.cgi?id=1894425

https://lists.debian.org/debian-lts-announce/2020/12/msg00005.html

https://security.gentoo.org/glsa/202012-07

https://security.netapp.com/advisory/ntap-20201202-0003/

https://www.postgresql.org/support/security/

Details

Source: MITRE

Published: 2020-11-16

Updated: 2020-12-07

Type: CWE-89

Risk Information

CVSS v2.0

Base Score: 6.5

Vector: AV:N/AC:L/Au:S/C:P/I:P/A:P

Impact Score: 6.4

Exploitability Score: 8

Severity: MEDIUM

CVSS v3.0

Base Score: 8.8

Vector: CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H

Impact Score: 5.9

Exploitability Score: 2.8

Severity: HIGH