SUSE SLED15 / SLES15 Security Update : MozillaThunderbird (SUSE-SU-2021:1854-1)

medium Nessus Plugin ID 150685
New! Plugin Severity Now Using CVSS v3

The calculated severity for Plugins has been updated to use CVSS v3 by default. Plugins that do not have a CVSS v3 score will fall back to CVSS v2 for calculating severity. Severity display preferences can be toggled in the settings dropdown.

Synopsis

The remote SUSE host is missing one or more security updates.

Description

The remote SUSE Linux SLED15 / SLES15 host has packages installed that are affected by multiple vulnerabilities as referenced in the SUSE-SU-2021:1854-1 advisory.

- Thunderbird unprotects a secret OpenPGP key prior to using it for a decryption, signing or key import task. If the task runs into a failure, the secret key may remain in memory in its unprotected state.
(CVE-2021-29950)

- The Mozilla Maintenance Service granted SERVICESTART access to BUILTIN|Users which, in a domain network, grants normal remote users access to start or stop the service. This could be used to prevent the browser update service from operating (if an attacker spammed the 'Stop' command); but also exposed attack surface in the maintenance service.Note: This issue only affected Windows operating systems older than Win 10 build 1709. Other operating systems are unaffected. (CVE-2021-29951)

- OpenPGP secret keys that were imported using Thunderbird version 78.8.1 up to version 78.10.1 were stored unencrypted on the user's local disk. The master password protection was inactive for those keys. Version 78.10.2 will restore the protection mechanism for newly imported keys, and will automatically protect keys that had been imported using affected Thunderbird versions. (CVE-2021-29956)

- If a MIME encoded email contains an OpenPGP inline signed or encrypted message part, but also contains an additional unprotected part, Thunderbird did not indicate that only parts of the message are protected.
(CVE-2021-29957)

Note that Nessus has not tested for this issue but has instead relied only on the application's self-reported version number.

Solution

Update the affected MozillaThunderbird, MozillaThunderbird-translations-common and / or MozillaThunderbird-translations- other packages.

See Also

https://bugzilla.suse.com/1185086

https://bugzilla.suse.com/1185633

https://bugzilla.suse.com/1186198

https://bugzilla.suse.com/1186199

http://www.nessus.org/u?d3087fb9

https://www.suse.com/security/cve/CVE-2021-29950

https://www.suse.com/security/cve/CVE-2021-29951

https://www.suse.com/security/cve/CVE-2021-29956

https://www.suse.com/security/cve/CVE-2021-29957

Plugin Details

Severity: Medium

ID: 150685

File Name: suse_SU-2021-1854-1.nasl

Version: 1.2

Type: local

Agent: unix

Published: 6/10/2021

Updated: 6/10/2021

Dependencies: ssh_get_info.nasl

Risk Information

CVSS Score Source: CVE-2021-29956

VPR

Risk Factor: Medium

Score: 6.1

CVSS v2

Risk Factor: Low

Base Score: 2.1

Temporal Score: 1.6

Vector: AV:L/AC:L/Au:N/C:P/I:N/A:N

Temporal Vector: E:U/RL:OF/RC:C

CVSS v3

Risk Factor: Medium

Base Score: 5.5

Temporal Score: 4.8

Vector: CVSS:3.0/AV:L/AC:L/PR:L/UI:N/S:U/C:H/I:N/A:N

Temporal Vector: E:U/RL:O/RC:C

Vulnerability Information

CPE: p-cpe:/a:novell:suse_linux:MozillaThunderbird, p-cpe:/a:novell:suse_linux:MozillaThunderbird-translations-common, p-cpe:/a:novell:suse_linux:MozillaThunderbird-translations-other, cpe:/o:novell:suse_linux:15

Required KB Items: Host/local_checks_enabled, Host/cpu, Host/SuSE/release, Host/SuSE/rpm-list

Exploit Ease: No known exploits are available

Patch Publication Date: 6/4/2021

Vulnerability Publication Date: 3/8/2021

Reference Information

CVE: CVE-2021-29950, CVE-2021-29951, CVE-2021-29956, CVE-2021-29957

SuSE: SUSE-SU-2021:1854-1