Fortinet FortiGate <= 5.6.13 / 6.0.x < 6.0.13 / 6.2.x < 6.2.8 / 6.4.x < 6.4.5 XSS (FG-IR-20-199)

medium Nessus Plugin ID 150156


The remote host is affected by a cross-site scripting vulnerability.


The remote host is running a FortiOS version prior or equal to 5.6.13, 6.0.x prior to 6.0.13, 6.2.x prior to 6.2.8, or 6.4.x prior to 6.4.6. It is, therefore, affected by a cross-site scripting vulnerability. An unauthenticated attacker may be able perform a reflected cross-site scripting attack by sending a request to the error page with malicious GET parameters.

Note that Nessus has not tested for this issue but has instead relied only on the application's self-reported version number.


Upgrade to Fortinet FortiOS version 6.0.13, 6.2.8, 6.4.6, 7.0.0 or later.

See Also

Plugin Details

Severity: Medium

ID: 150156

File Name: fortigate_FG-IR-20-199.nasl

Version: 1.3

Type: local

Family: Firewalls

Published: 6/3/2021

Updated: 6/7/2021

Risk Information


Risk Factor: Low

Score: 3


Risk Factor: Medium

Base Score: 4.3

Temporal Score: 3.2

Vector: AV:N/AC:M/Au:N/C:N/I:P/A:N

Temporal Vector: E:U/RL:OF/RC:C

CVSS Score Source: CVE-2021-26092


Risk Factor: Medium

Base Score: 6.1

Temporal Score: 5.3

Vector: CVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N

Temporal Vector: E:U/RL:O/RC:C

Vulnerability Information

CPE: cpe:/o:fortinet:fortios

Required KB Items: Host/Fortigate/version

Exploit Ease: No known exploits are available

Patch Publication Date: 5/30/2021

Vulnerability Publication Date: 5/30/2021

Reference Information

CVE: CVE-2021-26092

IAVA: 2021-A-0262