PostgreSQL 9.6.x < 9.6.22 / 10.x < 10.17 / 11.x < 11.12 / 12.x < 12.7 / 13.x < 13.3 Multiple Vulnerabilities

high Nessus Plugin ID 149850

Synopsis

The remote database server is affected by multiple vulnerabilities

Description

The version of PostgreSQL installed on the remote host is 9.6 prior to 9.6.22, 10 prior to 10.17, 11 prior to 11.12, 12 prior to 12.7, or 13 prior to 13.3. As such, it is potentially affected by multiple vulnerabilities :

- Buffer overrun from integer overflow in array subscripting calculations (CVE-2021-32027)

- Memory disclosure in INSERT ... ON CONFLICT ... DO UPDATE (CVE-2021-32028)

- Memory disclosure in partitioned-table UPDATE ... RETURNING (CVE-2021-32029)

Note that Nessus has not tested for this issue but has instead relied only on the application's self-reported version number.

Solution

Upgrade to PostgreSQL 9.6.22 / 10.17 / 11.12 / 12.7 / 13.3 or later

See Also

http://www.nessus.org/u?d682c4df

http://www.postgresql.org/support/security/CVE-2021-32029/

http://www.postgresql.org/support/security/CVE-2021-32028/

http://www.postgresql.org/support/security/CVE-2021-32027/

Plugin Details

Severity: High

ID: 149850

File Name: postgresql_20210513.nasl

Version: 1.6

Type: local

Family: Databases

Published: 5/24/2021

Updated: 4/11/2022

Configuration: Enable thorough checks

Risk Information

VPR

Risk Factor: Medium

Score: 5.9

CVSS v2

Risk Factor: Medium

Base Score: 6.5

Temporal Score: 4.8

Vector: AV:N/AC:L/Au:S/C:P/I:P/A:P

Temporal Vector: E:U/RL:OF/RC:C

CVSS Score Source: CVE-2021-32027

CVSS v3

Risk Factor: High

Base Score: 8.8

Temporal Score: 7.7

Vector: CVSS:3.0/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H

Temporal Vector: E:U/RL:O/RC:C

Vulnerability Information

CPE: cpe:/a:postgresql:postgresql

Exploit Ease: No known exploits are available

Patch Publication Date: 5/13/2021

Vulnerability Publication Date: 5/13/2021

Reference Information

CVE: CVE-2021-32027, CVE-2021-32028, CVE-2021-32029

IAVB: 2021-B-0036-S