openSUSE Security Update : apache-commons-io (openSUSE-2021-605)

medium Nessus Plugin ID 149616

Synopsis

The remote openSUSE host is missing a security update.

Description

This update for apache-commons-io fixes the following issues :

- CVE-2021-29425: Limited path traversal when invoking the method FileNameUtils.normalize with an improper input string (bsc#1184755)

This update was imported from the SUSE:SLE-15-SP2:Update update project.

Solution

Update the affected apache-commons-io packages.

See Also

https://bugzilla.opensuse.org/show_bug.cgi?id=1184755

Plugin Details

Severity: Medium

ID: 149616

File Name: openSUSE-2021-605.nasl

Version: 1.3

Type: local

Agent: unix

Published: 5/18/2021

Updated: 1/26/2022

Supported Sensors: Nessus Agent

Risk Information

CVSS Score Source: CVE-2021-29425

VPR

Risk Factor: Medium

Score: 5.8

CVSS v2

Risk Factor: Medium

Base Score: 5.8

Temporal Score: 5

Vector: AV:N/AC:M/Au:N/C:P/I:P/A:N

Temporal Vector: E:H/RL:OF/RC:C

CVSS v3

Risk Factor: Medium

Base Score: 4.8

Temporal Score: 4.6

Vector: CVSS:3.0/AV:N/AC:H/PR:N/UI:N/S:U/C:L/I:L/A:N

Temporal Vector: E:H/RL:O/RC:C

Vulnerability Information

CPE: p-cpe:/a:novell:opensuse:apache-commons-io, p-cpe:/a:novell:opensuse:apache-commons-io-javadoc, cpe:/o:novell:opensuse:15.2

Required KB Items: Host/local_checks_enabled, Host/SuSE/release, Host/SuSE/rpm-list

Exploit Available: true

Exploit Ease: Exploits are available

Patch Publication Date: 4/23/2021

Vulnerability Publication Date: 4/13/2021

Reference Information

CVE: CVE-2021-29425