Oracle NoSQL Database Multiple Vulnerabilities (Apr 2021 CPU)

critical Nessus Plugin ID 148977
New! Plugin Severity Now Using CVSS v3

The calculated severity for Plugins has been updated to use CVSS v3 by default. Plugins that do not have a CVSS v3 score will fall back to CVSS v2 for calculating severity. Severity display preferences can be toggled in the settings dropdown.

Synopsis

A database running on the remote host is affected by a multiple vulnerabilities.

Description

The version of Oracle NoSQL Database Enterprise running on the remote host is prior to 20.3.17. It is, therefore, affected by multiple vulnerabilities as referenced in the April 2021 CPU advisory.

- Vulnerability in Oracle NoSQL Database (component: Administration (Node.js)). The supported version that is affected is Prior to 20.3. Easily exploitable vulnerability allows unauthenticated attacker with network access via multiple protocols to compromise Oracle NoSQL Database.
Successful attacks of this vulnerability can result in unauthorized ability to cause a hang or frequently repeatable crash (complete DOS) of Oracle NoSQL Database. (CVE-2021-22883)

- Security-in-Depth issue in Oracle NoSQL Database (component: Administration (jackson-databind)).
This vulnerability cannot be exploited in the context of this product. (CVE-2019-14379)

- Vulnerability in Oracle NoSQL Database (component: Administration (Google Guava)). The supported version that is affected is Prior to 20.3. Easily exploitable vulnerability allows low privileged attacker with logon to the infrastructure where Oracle NoSQL Database executes to compromise Oracle NoSQL Database. Successful attacks of this vulnerability can result in unauthorized read access to a subset of Oracle NoSQL Database accessible data. (CVE-2020-8908)
- Vulnerability in Oracle NoSQL Database (component: Administration (Netty)). The supported version that is affected is Prior to 20.3. Easily exploitable vulnerability allows unauthenticated attacker with network access via HTTP to compromise Oracle NoSQL Database. Successful attacks of this vulnerability can result in unauthorized ability to cause a hang or frequently repeatable crash (complete DOS) of Oracle NoSQL Database. (CVE-2020-11612)

Note that Nessus has not tested for these issues but has instead relied only on the application's self-reported version number.

Solution

Upgrade to Oracle NoSQL Database Enterprise version 20.3.17 or later.

See Also

https://www.oracle.com/security-alerts/cpuapr2021.html#AppendixNSQL

https://www.oracle.com/security-alerts/cpuapr2021verbose.html

https://www.oracle.com/a/tech/docs/cpuapr2021cvrf.xml

Plugin Details

Severity: Critical

ID: 148977

File Name: oracle_nosql_cpu_apr_2021.nasl

Version: 1.4

Type: local

Agent: unix

Family: Databases

Published: 4/23/2021

Updated: 4/30/2021

Dependencies: oracle_nosql_nix_installed.nbin

Risk Information

CVSS Score Source: CVE-2019-14379

VPR

Risk Factor: Critical

Score: 9

CVSS v2

Risk Factor: High

Base Score: 7.5

Temporal Score: 5.9

Vector: AV:N/AC:L/Au:N/C:P/I:P/A:P

Temporal Vector: E:POC/RL:OF/RC:C

CVSS v3

Risk Factor: Critical

Base Score: 9.8

Temporal Score: 8.8

Vector: CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H

Temporal Vector: E:P/RL:O/RC:C

Vulnerability Information

CPE: x-cpe:/a:oracle:nosql_database

Required KB Items: installed_sw/Oracle NoSQL Database

Exploit Available: true

Exploit Ease: Exploits are available

Patch Publication Date: 4/22/2021

Vulnerability Publication Date: 10/12/2020

Reference Information

CVE: CVE-2019-14379, CVE-2020-8908, CVE-2020-11612, CVE-2020-13956, CVE-2020-24553, CVE-2021-21290, CVE-2021-22883, CVE-2021-22884, CVE-2021-23840