MariaDB 10.4.0 < 10.4.18 A Vulnerability

high Nessus Plugin ID 148827

Synopsis

The remote database server is affected by a vulnerability

Description

The version of MariaDB installed on the remote host is prior to 10.4.18. It is, therefore, affected by a vulnerability as referenced in the mdb-10418-rn advisory.

- A remote code execution issue was discovered in MariaDB 10.2 before 10.2.37, 10.3 before 10.3.28, 10.4 before 10.4.18, and 10.5 before 10.5.9; Percona Server through 2021-03-03; and the wsrep patch through 2021-03-03 for MySQL. An untrusted search path leads to eval injection, in which a database SUPER user can execute OS commands after modifying wsrep_provider and wsrep_notify_cmd. NOTE: this does not affect an Oracle product. (CVE-2021-27928)

Note that Nessus has not tested for this issue but has instead relied only on the application's self-reported version number.

Solution

Upgrade to MariaDB version 10.4.18 or later.

See Also

https://mariadb.com/kb/en/mdb-10418-rn

Plugin Details

Severity: High

ID: 148827

File Name: mariadb_10_4_18.nasl

Version: 1.3

Type: remote

Family: Databases

Published: 4/20/2021

Updated: 4/21/2021

Configuration: Enable paranoid mode

Risk Information

VPR

Risk Factor: High

Score: 7.4

CVSS v2

Risk Factor: High

Base Score: 9

Temporal Score: 7

Vector: AV:N/AC:L/Au:S/C:C/I:C/A:C

Temporal Vector: E:POC/RL:OF/RC:C

CVSS Score Source: CVE-2021-27928

CVSS v3

Risk Factor: High

Base Score: 7.2

Temporal Score: 6.5

Vector: CVSS:3.0/AV:N/AC:L/PR:H/UI:N/S:U/C:H/I:H/A:H

Temporal Vector: E:P/RL:O/RC:C

Vulnerability Information

CPE: cpe:/a:mariadb:mariadb

Required KB Items: Settings/ParanoidReport

Exploit Available: true

Exploit Ease: Exploits are available

Patch Publication Date: 2/22/2021

Vulnerability Publication Date: 3/19/2021

Reference Information

CVE: CVE-2021-27928