openSUSE Security Update : bcc (openSUSE-2021-535)

medium Nessus Plugin ID 148435

Synopsis

The remote openSUSE host is missing a security update.

Description

This update for bcc fixes the following issues :

- Enabled PIE for bcc-lua if lua support is enabled (bsc#1183399)

This update was imported from the SUSE:SLE-15-SP2:Update update project.

Solution

Update the affected bcc packages.

See Also

https://bugzilla.opensuse.org/show_bug.cgi?id=1183399

Plugin Details

Severity: Medium

ID: 148435

File Name: openSUSE-2021-535.nasl

Version: 1.1

Type: local

Agent: unix

Published: 4/12/2021

Updated: 4/12/2021

Dependencies: ssh_get_info.nasl

Risk Information

Risk Factor: Medium

Vulnerability Information

CPE: p-cpe:/a:novell:opensuse:bcc-debuginfo, p-cpe:/a:novell:opensuse:bcc-debugsource, p-cpe:/a:novell:opensuse:bcc-devel, p-cpe:/a:novell:opensuse:bcc-examples, p-cpe:/a:novell:opensuse:bcc-lua, p-cpe:/a:novell:opensuse:bcc-lua-debuginfo, p-cpe:/a:novell:opensuse:bcc-tools, p-cpe:/a:novell:opensuse:libbcc0, p-cpe:/a:novell:opensuse:libbcc0-debuginfo, p-cpe:/a:novell:opensuse:python2-bcc, p-cpe:/a:novell:opensuse:python3-bcc, cpe:/o:novell:opensuse:15.2

Required KB Items: Host/local_checks_enabled, Host/SuSE/release, Host/SuSE/rpm-list, Host/cpu

Patch Publication Date: 4/10/2021

Vulnerability Publication Date: 4/10/2021