PostgreSQL 11.x < 11.11 / 12.x < 12.6 / 13.x < 13.2 Multiple Vulnerabilities

medium Nessus Plugin ID 148419
New! Plugin Severity Now Using CVSS v3

The calculated severity for Plugins has been updated to use CVSS v3 by default. Plugins that do not have a CVSS v3 score will fall back to CVSS v2 for calculating severity. Severity display preferences can be toggled in the settings dropdown.

Synopsis

The remote database server is affected by multiple vulnerabilities

Description

The version of PostgreSQL installed on the remote host is 11 prior to 11.11, 12 prior to 12.6, or 13 prior to 13.2. As such, it is potentially affected by multiple vulnerabilities :

- An information leak was discovered in postgresql in versions before 13.2, before 12.6 and before 11.11.
A user having UPDATE permission but not SELECT permission to a particular column could craft queries which, under some circumstances, might disclose values from that column in error messages. An attacker could use this flaw to obtain information stored in a column they are allowed to write but not read.
(CVE-2021-3393)

- A flaw was found in PostgreSQL in versions before 13.2, before 12.6, before 11.11. This flaw allows a user with SELECT privilege on one column to craft a special query that returns all columns of the table.
The highest threat from this vulnerability is to confidentiality (CVE-2021-20229)

Note that Nessus has not tested for this issue but has instead relied only on the application's self-reported version number.

Solution

Upgrade to PostgreSQL 11.11 / 12.6 / 13.2 or later

See Also

http://www.nessus.org/u?56673af4

https://access.redhat.com/security/cve/CVE-2021-20229

https://access.redhat.com/security/cve/CVE-2021-3393

Plugin Details

Severity: Medium

ID: 148419

File Name: postgresql_20210211.nasl

Version: 1.7

Type: local

Agent: windows, macosx, unix

Family: Databases

Published: 4/9/2021

Updated: 6/18/2021

Dependencies: postgres_installed_windows.nbin, postgres_installed_nix.nbin, postgresql_version.nbin

Risk Information

CVSS Score Source: CVE-2021-20229

VPR

Risk Factor: Low

Score: 2.2

CVSS v2

Risk Factor: Medium

Base Score: 4

Temporal Score: 3

Vector: AV:N/AC:L/Au:S/C:P/I:N/A:N

Temporal Vector: E:U/RL:OF/RC:C

CVSS v3

Risk Factor: Medium

Base Score: 4.3

Temporal Score: 3.8

Vector: CVSS:3.0/AV:N/AC:L/PR:L/UI:N/S:U/C:L/I:N/A:N

Temporal Vector: E:U/RL:O/RC:C

Vulnerability Information

CPE: cpe:/a:postgresql:postgresql

Exploit Ease: No known exploits are available

Patch Publication Date: 2/11/2021

Vulnerability Publication Date: 2/11/2021

Reference Information

CVE: CVE-2021-3393, CVE-2021-20229

IAVB: 2021-B-0023-S